1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to access port based VirtualHost

Discussion in 'Plesk for Linux - 8.x and Older' started by soopadoubled, Mar 30, 2010.

  1. soopadoubled

    soopadoubled Guest

    0
     
    I've installed Google Sitemap Generator on a CentOS 5.2 server running Plesk 8.6.

    GSG includes a conf file in the main httpd.conf that sets up a virtual host on my server IP at port 8181. The documents for this are located at /usr/local/google-sitemap-generator/admin-console and appear to have the correct permissions.

    According to their documentation I should be able to then access the control panel at http://myip:8181

    However, I'm unable to access the control panel and my browser simply returns:

    "Safari cant open the page http://myip:8181/ because the server where this page is located isnt responding"

    (I've substituted my IP for security).

    I know the port is open and is listening (checked via netstat and nmap), and I have the port open on iptables. I've double checked my VirtualHosts throughout the server and everything seems to be fine.

    I can only assume there's an issue with virtual hosts, but what specifically I have no idea.

    Am I making some glaring error, or could there be something specific in my configuration that is causing me issues?

    Any advice would be greatly appreciated!

    Cheers,

    Ian

    P.s. Here's the GSG .conf file that is included inside the main httpd.conf:

    Code:
    Listen 8181
    NameVirtualHost *:8181
    <VirtualHost *:8181>
    DocumentRoot "/usr/local/google-sitemap-generator/admin-console"
    ScriptAlias /cgi-bin/ "/usr/local/google-sitemap-generator/admin-console/cgi-bin/"
    
     <Directory "/usr/local/google-sitemap-generator/admin-console">
       Allow from all
        Options ExecCGI
        DirectoryIndex
      </Directory>
    </VirtualHost>
    
    LoadModule google_sitemap_generator_module /usr/local/google-sitemap-generator/lib/mod_sitemap.so
    
    
     
  2. soopadoubled

    soopadoubled Guest

    0
     
    It turns out that my VPS provider operates a firewall on the VPS containers.

    By some massive fluke, any previous services I had configured (including SSH) I had set on some of the few ports open on their firewall.

    I had never considered another firewall to be the issue, having successfully used (by sheer luck) 'random' ports in the past.


    Ian
     
Loading...