1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Unable to increase upload limit since upgrade?

Discussion in 'Plesk 11.x for Linux' started by Slavik, Jul 12, 2012.

  1. Slavik

    Slavik Basic Pleskian

    17
    85%
    Joined:
    Mar 23, 2011
    Messages:
    44
    Likes Received:
    0
    So before the upgrade one of my accounts had an extra pvp upload limit set.

    memory_limit = 512M
    max_execution_time = 1800
    upload_max_filesize = 128M
    max_input_time = 1800
    post_max_size = 256M


    Despite these still being set the user is unable to uload anything larger than a few mb?

    Any ideas?
     
  2. Slavik

    Slavik Basic Pleskian

    17
    85%
    Joined:
    Mar 23, 2011
    Messages:
    44
    Likes Received:
    0
    Bump for fixes :)
     
  3. Slavik

    Slavik Basic Pleskian

    17
    85%
    Joined:
    Mar 23, 2011
    Messages:
    44
    Likes Received:
    0
    Nearly a week without a single reply?

    When I see a stable release pushed in the update manager, I expect it to be that.

    Not to now have customers moaning because basic features such as setting upload size are not working.
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Does running

    Code:
    <?php phpinfo() ?>
    Show the changes set as changed or NOT changed?
    How are you making those changes?

    By editing /var/www/vhosts/domain.com/etc/php.ini or /etc/php.ini ??
    Dont also forget to make a restart of apache after saving ..
     
  5. Slavik

    Slavik Basic Pleskian

    17
    85%
    Joined:
    Mar 23, 2011
    Messages:
    44
    Likes Received:
    0
    PHPinfo shows the right values.

    Changes made at domain level.

    Obviously have restarted after the changes done...
     
  6. theamigaone

    theamigaone Guest

    0
     
    This could be down to the apache mod_fcgid.c which enforces an upload limit if you use fastcgi

    theres a flag called

    FcgidMaxRequestLen

    But it seems on our site we are having a problem too where now we are limited to 16mb upload and its ignoring

    /etc/http/conf.d/fcgid.conf

    it seems to have happened since the Plesk 11 upgrade.
     
  7. DylanMacak

    DylanMacak Guest

    0
     
    Upload Large Files Issue

    Same thing here, no matter what I do, I just can't upload large files. By large, I mean anything larger than 16MB.

    /etc/httpd/conf.d/fcgid.conf show correct value for
    FcgidMaxRequestLen 1073741824 (1GB)

    but in the error log it is still quitting after 16783072 (16MB). It seems to me that there's some setting somewhere that overwrites FcgidMaxRequestLen set in fcgid.conf.

    I changed all values in php.ini to a very large values, but nothing helps:
    file_uploads On
    upload_max_filesize 600M
    max_input_time 1200
    memory_limit 1G
    max_execution_time 1200
    post_max_size 700M


    I am on Media Temple (dv) server.

    Any ideas?
     
  8. KatherineD

    KatherineD Guest

    0
     
    Hi DylanMacak,

    Some of the values you've included are definitely a bit high. But it is tough to distinguish what the issue might be since we can't take a look at your server. If you're still having issues, please open up a report request in your AccountCenter under the Support tab. If you have any questions, please let us know. We hope to help get this issue resolved for you!

    Kat D.
    (mt) Media Temple
    Social Media Team
     
  9. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    What I noticed is that the php settings you set in the control panel are effective only when you run PHP as Fast CGI rather than as an Apache module.

    Then, you restart apache (though a change in panel should work right away)
     
  10. DylanMacak

    DylanMacak Guest

    0
     
    Katherine,
    already submitted a ticked to Media Temple, but they do not support dedicated packages, they just sent me a few links where the problem is described in more details.

    I tried everything that was suggested and I am still having issues.

    Here's my error log:
    mod_fcgid: HTTP request length 16781472 (so far) exceeds MaxRequestLen (16777216)

    I was wondering if you know if there's another file where FcgidMaxRequestLen is set and maybe that overrides my main setting in /etc/httpd/conf.d/fcgid.conf ?
     
  11. DylanMacak

    DylanMacak Guest

    0
     
    Some progress...

    Well, thanks to IgorG from Parallels Team, here's some info about where MaxRequestLen is set as well, at least on Media Temple (dv).

    /usr/local/psa/admin/conf/templates/default/domain/domainVirtualHost.php

    Still getting an error though, but now I know I need to look somewhere else...
     
  12. DylanMacak

    DylanMacak Guest

    0
     
    Solved.

    OK, here's how I solved it in case somebody has the same problem...

    First, I found FcgidMaxRequestLen in /usr/local/psa/admin/conf/templates/default/domain/domainVirtualHost.php and increased it to 1G (FcgidMaxRequestLen 1073741824). That did not work.

    The FcgidMaxRequestLen value that replaced the value set in /etc/httpd/conf.d/fcgid.conf can be found here: /var/www/vhosts/your_domain_name_here/conf/last_httpd_ip_default.include

    It was incorrectly set to 16777216. I increased it to 1073741824 and was able to upload large files. I tested 120MB file and everything worked fine.
     
  13. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Thanks for sharing that information Dylan. Its actually a common problem ...
     
  14. KatherineD

    KatherineD Guest

    0
     
    DylanMacak,

    I'm sorry for the delay in my response, I see that you were able to resolve your issue though! If there are any other questions, please let me know or you can always reach us via support request or phone. Have a great week! :)

    Kat D.
    (mt) Media Temple
    Social Media Team
     
  15. KirillU

    KirillU New Pleskian

    12
    85%
    Joined:
    Aug 26, 2011
    Messages:
    6
    Likes Received:
    0
    Thank you, DylanMacak, It works!

    2 Parallels team - need automated fix, because it is quite impossible to fix it manually on all domains/subdomains.
    the best was were to include this option to service plan config (php options) in admin panel
     
  16. Alexey.Plotnitsky

    Alexey.Plotnitsky Regular Pleskian

    16
    55%
    Joined:
    Jan 19, 2012
    Messages:
    218
    Likes Received:
    3
    DylanMacak, KirillU,

    You should copy modified template file to
    /usr/local/psa/admin/conf/templates/custom/domain/domainVirtualHost.php

    There it will not be affected by Plesk update.
     
  17. tjillinois

    tjillinois New Pleskian

    10
     
    Joined:
    Oct 13, 2012
    Messages:
    2
    Likes Received:
    0
    No Effect

    Greetings,

    I'm running into this problem. First users complained about an inability to upload. This was the standard PHP memory and upload limit which I fixed within plesk.

    This generated a different error:
    [Fri Oct 12 16:16:18 2012] [warn] [client 127.0.0.1] mod_fcgid: HTTP request length 16784656 (so far) exceeds MaxRequestLen (16777216), referer:

    Obviously I've found this thread that discusses this issue.

    Due to this I've attempted to fix fcgid in a number of ways:

    1) Change it on an individual hosts config:
    /var/www/vhosts/host_dns/conf/last_httpd.include

    2)Changed teh default template:
    /usr/local/psa/admin/conf/templates/default/domain/domainVirtualHost.php

    3)Also the main apache config:
    /etc/apache2/mods-available/fcgid.conf

    I've restarted Apache via command line, and within the plesk panel and also the psa service. But despite this I'm still seeing the above error. Any thoughts as to why this change isn't having an effect?
     
  18. tjillinois

    tjillinois New Pleskian

    10
     
    Joined:
    Oct 13, 2012
    Messages:
    2
    Likes Received:
    0
    Restart after config changes

    For those curious to get these settings to actually apply you have to run this command:

    /usr/local/psa/admin/bin/httpdmng --reconfigure-all
     
  19. Alexey.Plotnitsky

    Alexey.Plotnitsky Regular Pleskian

    16
    55%
    Joined:
    Jan 19, 2012
    Messages:
    218
    Likes Received:
    3
    Hi tjillinois,
    1) You should not modify /var/www/vhosts/host_dns/conf/last_httpd.include
    since it is a link to latest generated config file by Plesk. It will be overwritten by Plesk on next vhost modification

    2) It is better to copy your domainVirtualHost.php template to
    /usr/local/psa/admin/conf/templates/custom/domain/domainVirtualHost.php
    There it will not be overwritten during next Plesk update
     
  20. Atramasis

    Atramasis Basic Pleskian

    13
    60%
    Joined:
    Oct 22, 2012
    Messages:
    42
    Likes Received:
    0
    To sum it up

    1. Copy /usr/local/psa/admin/conf/templates/default/domain/domainVirtualHost.php to /usr/local/psa/admin/conf/templates/custom/domain/domainVirtualHost.php

    2. Edit FcgidMaxRequestLen in line ~126 to FcgidMaxRequestLen 1073741824

    3. Run /usr/local/psa/admin/bin/httpdmng --reconfigure-all



    It worked for me, but it would be easier if we could change it in the panel (system wide or per domain). Please.
     
Loading...