1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Update php, mysql, and phpmyadmin with plesk 9.5.4

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by KévinB, Jul 17, 2012.

  1. KévinB

    KévinB New Pleskian

    10
     
    Joined:
    Jul 17, 2012
    Messages:
    2
    Likes Received:
    0
    Hi,

    I have a server using parallels plesk panel 9.5.4, and centOS 5.7.
    It runs
    -> php 5.3.3
    -> mysql 5.0.95
    -> phpmyadmin 2.11
    (-> apache 2.2)

    I'd like to update to the following
    -> php 5.4
    -> mysql 5.5
    -> phpmyadmin 3.5
    (-> apache 2.4)

    How can I do this safely on my plesk-driven server ?

    Tanks
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
  3. KévinB

    KévinB New Pleskian

    10
     
    Joined:
    Jul 17, 2012
    Messages:
    2
    Likes Received:
    0
    Thank you !

    I encountered some errors during the upgrade, but Google knew them :). Here they are, in case someone reads this thread :
    -> http://kb.parallels.com/fr/111630
    -> http://forum.ovh.com/showthread.php?t=69508 (this one basically says "yum remove nmap")

    I now have those installed on my server :
    - php5.3.14 → at least it's now the very last update of php5.3 branch. But I'd like to upgrade to php5.4.
    - mysql 5.5.25 → perfect !
    - phpmyadmin 2.11 → no problem here : anyway I also wanted to access it from outside the control panel, and the method for this let me easily choose phpmyadmin3.5. I assume that if I want the panel version to be 3.5 as well, I'd just have to move the 2.11 folder and replace it with a link to my 3.5 folder.


    I edited /etc/yum.repos.d/atomic.repo with vi, and enabled atomic-testing instead of atomic, but both "yum update php" and "yum upgrade php" said "No Packages marked for Update".
    How can I upgrade to php 5.4 ?

    Thanks
     
Loading...