1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

updating Plesk - lost control of Control Panel

Discussion in 'Plesk for Linux - 8.x and Older' started by tleyva, Jun 20, 2005.

  1. tleyva

    tleyva Guest

    0
     
    From within the Control Panel, I triggered the update feature which downloaded a bunch of packages for not only Plesk itself but for the underlying system, apparently it overwrote the current version of Apache with a version of Apache which wasn’t Plesk compatible, in that the su exec binary apparently didn’t match Plesk or what Plesk was expecting. Basically as soon as Plesk completed the updates CGI broke, and to fix it I copied over a new su exec with a backup copy of it. After doing so CGI started to work again but now the Plesk Control Panel doesn’t. And to further clarify the control panel didn’t work as soon as I updated Plesk.

    Trying to bring up Plesk resulted in a blank screen, aside from the Plesk header. I turned on error reporting in Plesk's own php.ini, and it showed that it was unable to find one of the internal functions. I'm not really able to debug beyond that, not having access to Plesk sources; I'm betting that it overwrote some of the PSA files, but didn't complete the upgrade (nor back out) correctly.

    Can anyone provide me with any insight on how to fix this problem? I am using Suse 9.1 & Plesk version 7.52.

    Thank you in advance.
     
  2. WebDork

    WebDork Guest

    0
     
    My server has been like this now for a couple of weeks. Stupid PLESK. Definitely getting more and more closer to installing CPANEL and being done with it. Everytime I upgrade PLESK something dies. Then of course they expect you to pay them for them to tell you how to fix it. What a load of &^*($#@. Anyway - there are a couple of posts on this forum for the same problem. Unfortunately none of the fixes worked for me. Do a search for "blank".
     
  3. tleyva

    tleyva Guest

    0
     
    WebDork thanks for the info. I will try to search the forum for what you suggested. Let's hope that the fix works for me. :(

    However I would like to find out if you are able to find a fix beyond what you have already tried. Please keep me informed. :D

    My Server Admin suggests that we just go ahead and reinstall Plesk and then reconfigure the server. To be honest I don't want to go down this road for the simple reason that according to my Server Admin it will take a week to do this, while I have a RAID setup and will not experience any downtime I can't help but cringe when I think of all the billable hours that my Server Admin will rack up. :mad: Do you think we should just reinstall Plesk?

    Would appreciate any advice you or anyone else could offer.

    Thanks
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  5. tleyva

    tleyva Guest

    0
     
    Thanks for the advice phoenix, I will give it a shot. Will let you know how it works out. :D
     
Loading...