1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrade from 10.0.1 to 10.2.0 crashed the Plesk Panel

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by george.damian, Apr 6, 2011.

  1. george.damian

    george.damian New Pleskian

    15
    60%
    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Hello,
    I need your help : we wanted to upgrade to the new Plesk Panel 10.2.0 but it crashed and now the panel doesn't load at all and the mail service doesn't work.
    We don't even know if we can roll-back or something like that. please help!
     
  2. Shawn M

    Shawn M Basic Pleskian

    22
     
    Joined:
    Oct 16, 2009
    Messages:
    79
    Likes Received:
    0
    Hi,

    Same issue here. I installed 10.2 from 10.1 and I am getting this error when I go to load the panel:
    Internet Explorer cannot display the webpage.
     
  3. george.damian

    george.damian New Pleskian

    15
    60%
    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Hi,
    Did your upgrade went ok ? I got an error with the database.
    I tried to repair the installation but I get this error :

    ===> Upgrading database

    Trying to start service mysqld... done
    Trying to establish test connection... connected
    done
    Trying to find psa database... version is 010110
    DATABASE ERROR!!!
    Previous product version is 10.9.0, but previous database
    version is 010110. In most of cases it is result of
    previous upgrade try failure. Please, restore previous version
    from backup, and try again or contact technical support.

    ERROR while trying to check database version
    Check the error reason(see log file: /tmp/pp10.10.1-bootstrapper.110406.18.15.log), fix and try again

    Any ideas?
     
  4. Shawn M

    Shawn M Basic Pleskian

    22
     
    Joined:
    Oct 16, 2009
    Messages:
    79
    Likes Received:
    0
    I tried running:
    # /usr/local/psa/bootstrapper/pp10.10.1-bootstrapper/bootstrapper.sh repair

    Then ran:
    # /etc/init.d/psa start

    Still, the starting of Plesk failed.

    My sites are up fine.
     
  5. george.damian

    george.damian New Pleskian

    15
    60%
    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Does your e-mail work?
     
  6. Shawn M

    Shawn M Basic Pleskian

    22
     
    Joined:
    Oct 16, 2009
    Messages:
    79
    Likes Received:
    0
    I don't use email through my server.
     
  7. Gredini

    Gredini New Pleskian

    16
    35%
    Joined:
    Feb 2, 2011
    Messages:
    12
    Likes Received:
    0
    Try:

    /usr/local/psa/bin/sso --disable
     
  8. Shawn M

    Shawn M Basic Pleskian

    22
     
    Joined:
    Oct 16, 2009
    Messages:
    79
    Likes Received:
    0
    Didn't Work.
     
  9. Shawn M

    Shawn M Basic Pleskian

    22
     
    Joined:
    Oct 16, 2009
    Messages:
    79
    Likes Received:
    0
    Does Parallels have any solution to this?
     
  10. Mickael Salfati

    Mickael Salfati Regular Pleskian

    27
     
    Joined:
    Apr 6, 2009
    Messages:
    178
    Likes Received:
    1
    I had the same issue, I stop psa and restart it and all is back. Howewer I have exactly the same message and no way to upgrade to 10.2.0 from 10.1.1 (Debian 5 Lenny)
    Code:
     Trying to find psa database... version is 010101
    DATABASE ERROR!!!
    Previous product version is 10.9.0, but previous database
    version is 010101. In most of cases it is result of
    previous upgrade try failure. Please, restore previous version
    from backup, and try again or contact technical support.
     
  11. Mickael Salfati

    Mickael Salfati Regular Pleskian

    27
     
    Joined:
    Apr 6, 2009
    Messages:
    178
    Likes Received:
    1
    For others, I finally found the solution with a bit of investigation. So I executed:
    /usr/local/psa/bootstrapper/pp10.10.1-bootstrapper/bootstrapper.sh

    And finally launch normally upgrade to 10.2 from the panel ;)
    Plesk upgrade 10.2 is done, be patient this upgrade can take some time ;)
     
  12. CCHickman

    CCHickman Regular Pleskian

    25
    40%
    Joined:
    Oct 11, 2003
    Messages:
    112
    Likes Received:
    0
    I'm with Mickael on the fact that THAT seems to fix a LOT of problems.
     
  13. David Harris

    David Harris Basic Pleskian

    20
    40%
    Joined:
    Apr 22, 2009
    Messages:
    42
    Likes Received:
    0
    Location:
    Pyrenees, France.
    10.11.0 to 10.2 upgrade fail

    Same problem here, tried the solutions above with no joy. Panel not loading. Sites are fine and mail, psa will not start for some reason? Install log here... http://pastebin.ca/2047380

    Any suggestions how to get the panel working again please.

    Thanks.

    Also when I run apt-get update and up grade I get a load of stuff held back with regards to plesk.

    apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages have been kept back:
    libpam-plesk linux-generic linux-image-generic linux-restricted-modules-generic plesk-base plesk-billing plesk-billing-plugins plesk-core plesk-l10n plesk-mail-qc-driver psa
    psa-atmail psa-awstats-configurator psa-backup-manager psa-cs-gs psa-drweb-configurator psa-fileserver psa-firewall psa-health-monitor psa-horde psa-imp psa-logrotate
    psa-mail-driver-common psa-mailman-configurator psa-php5-configurator psa-pylibplesk psa-rubyrails-configurator psa-spamassassin psa-updates psa-vhost psa-vpn psa-watchdog
    sw-engine
    0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
     
    Last edited: Apr 17, 2011
  14. David Harris

    David Harris Basic Pleskian

    20
    40%
    Joined:
    Apr 22, 2009
    Messages:
    42
    Likes Received:
    0
    Location:
    Pyrenees, France.
    Ubuntu fix...

    Can we have one for this problem please. Looks like it might be a sso conflict looking at other peoples posts who are having problems after upgrading to 10.2
     
  15. David Harris

    David Harris Basic Pleskian

    20
    40%
    Joined:
    Apr 22, 2009
    Messages:
    42
    Likes Received:
    0
    Location:
    Pyrenees, France.
    Last edited: Apr 17, 2011
Loading...