1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgraded to 7.5 now plesk does not work

Discussion in 'Plesk for Linux - 8.x and Older' started by tundra96, Dec 14, 2004.

  1. tundra96

    tundra96 Guest

    0
     
    I ran the upgrade to 7.5 and this happened at the end:

    Trying to stop MySQL server...
    WARNING!
    During the stop found some small problems(see log file: /tmp/psa_7.5.0_RedHat_9_build75041208.19_upgrade.log)

    Continue...

    
    ERROR while trying to stop
    Check the error reason(see log file: /tmp/psa_7.5.0_RedHat_9_build75041208.19_upgrade.log), fix and try again

    Aborting...

    error: %pre(psa-7.5.0-rh9.build75041208.19) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-7.5.0-rh9.build75041208.19
    Generate public/private keys pair for server ...
    domain_bu: Server's keys pair already exists
    domain_bu: Server's keys pair already exists
    Server keys generating done
    ===> Reading /etc/tomcat4/tomcat4.conf ...
    ===> Updating /etc/psa/psa.conf...
    ===> Reading /etc/psa/psa.conf ...

    <html>
    <head> <title>Key Error</title>
    <body bgcolor='#ffffff'>
    <script> <!--
    alert('The key that you are using is invalid for the product version you are running.\nTo purchase a new key go to the Plesk Online Store at www.sw-soft.com or contact\nsales@sw-soft.com.');
    //--> </script>
    </body> </html>
    error: %post(psa-api-rpc-1.3.2-3) scriptlet failed, exit status 255
    ===> Reading /etc/psa/psa.conf ...
    /usr/local/psa/admin/bin/httpsdctl stop: httpd stopped
    Stopping Plesk: [ OK ]
    uninstall_post.sh

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Tue Dec 14 10:04:21 2004

    ***** end of log file *****



    15minuteservers tried to add the new key but they get this error:

    user psaadm not found
    user psaadm not found


    My question is how do I fix this without having to re-image the server ?
     
  2. chickenbak

    chickenbak Guest

    0
     
    I had this same problem. Download the rpm version, and install both of the rpms related to the key within the base directory. I had some other issues as well with the database, so I ended up nixing it, and reinstalling it (I don't use 3.23, I use Arts...which I believe are at 4.22).

    I ran into the problem with psaadm as well...I believe what I ended up doing was telling it to install the rpm instead of -Uvh, and it ended up creating the psaadm group...and also ended up actually doing an upgrade instead of a reinstall, so I was happy!
     
Loading...