1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Upgrading from 9.2.3 to 10.1.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by PTS, Jan 25, 2011.

  1. PTS

    PTS New Pleskian

    20
    40%
    Joined:
    Nov 20, 2009
    Messages:
    23
    Likes Received:
    0
    I just got a new dedicated server which has Plesk 9.2.3 installed.

    What is the best and safest way to update to the most current version?

    Should I upgrade directly to 10.1.1 or update to each individual version one at a time?
     
  2. lhwparis

    lhwparis Guest

    0
     
    new server? update directly to 10.1.1
     
  3. PTS

    PTS New Pleskian

    20
    40%
    Joined:
    Nov 20, 2009
    Messages:
    23
    Likes Received:
    0
    Ouch, upgraded from 9.2.3 to 10.1.1 and the system pretty much exploded. I upgraded via CLI.

    Massive errors on login like:

    Internal error: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'psa.smb_productUpgrades' doesn't exist

    ERROR: Zend_Db_Statement_Exception
    SQLSTATE[42S02]: Base table or view not found: 1146 Table 'psa.smb_apsInstances' doesn't exist

    Going to reprovision server and try upgrading again version by version.
     
    Last edited: Jan 25, 2011
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
  5. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    After update

    Internal error: SQLSTATE[42S22]: Column not found: 1054 Unknown column 's.custom' in 'where clause'

    Message SQLSTATE[42S22]: Column not found: 1054 Unknown column 's.custom' in 'where clause'
    File Pdo.php
    Line 238
    Type Zend_Db_Statement_Exception
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Did you try bootstraper repair as it is described in KB article?
     
  7. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    Yes, I did, just mail restore is around 2 hours of update :)
    Over 5000 email address.

    Now seems to be working.
    But still update is not done :)
     
  8. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    hi, i have the same problem

    and in plesk:

    when i restart my server the panel shows:

    but the updater shows:

    we can that be?
    when i go to the link "domains" plesk shows:

    it was a automatic update from 10.0.1 to 10.1.1 - are we just beta-testers?
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Your mysql server was not running for some reason during upgrade procedure. Therefore database was not correctly upgraded without connection to mysql server.
     
  10. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    websites are available, mysql run - but it does not a restart, just when i restart the whole server.

    plesk show the following message just in "clients, domains, abonnements":

    all other meuitems (serversettings, tools, modules, etc.) working normal.
     
    Last edited: Feb 2, 2011
  11. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    now i got emails:

    whats wrong with paralells?
    just build plesk for paid support?
     
  12. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
  13. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    yes i tried:

    /usr/local/psa/bin/init_conf --update -passwd ********

    i have 3 folders in /usr/local/psa/bootstrapper

    pp10.8.0-bootstrapper
    pp10.9.0-bootstrapper
    pp10.10.0-bootstrapper

    bootstrapper repair:

    and all the same.....

    :(
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Are you sure that your MySQL server is started?
     
  15. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    yes, all websites with mysql databases are running (wbb3, joomla, etc.)
     
  16. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    According to
    MySQL server is not running.
     
  17. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    youre right, i made:
    /etc/init.d/mysql status

    and it shows:
    Checking for service MySQL: unused

    now i make:
    /etc/init.d/mysql start

    then it shows:
    Trying to start service mysql... Starting service MySQL warning: /var/lib/mysql/mysql.sock didn't appear within 30 seconds

    and all websites are down...............
     
  18. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    Well. Now I know that you should fix your MySQL server...
     
  19. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    when you tell me what plesk had done with my sql server......
     
  20. ReinhartK

    ReinhartK New Pleskian

    16
    35%
    Joined:
    Feb 1, 2011
    Messages:
    13
    Likes Received:
    0
    its BIND that block the port 3306!

    made:
    rcnamed stop

    then:
    /etc/init.d/mysql start

    and:
    rcnamed start

    now it shows after:
    /etc/init.d/mysql status

    but always the same message in plesk:

    and to the link: http://kb.odin.com/en/9330

    my password doesnt contains a + or %, etc. just numbers and letters


    EDIT:

    it works now, the second try was successfull! :)

    thank you igor!
     
    Last edited: Feb 3, 2011
Loading...