1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

vhost.conf does not work

Discussion in 'Plesk for Linux - 8.x and Older' started by thijsh, Nov 10, 2005.

  1. thijsh

    thijsh Guest

    I tried with a simple RewriteRule if my Mod_rewrite is working but the following
    is not showing

    In the following file
    is written:

    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteRule ^silly\.html$ /existing_page.html [L]

    I also did:
    /usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=gd.be
    service httpd restart

    Is there something wrong with my RewriteRule or is something else wrong?

    Thanks in advance
  2. thijsh

    thijsh Guest

    mydomain.be = gd.be
  3. thijsh

    thijsh Guest

    Does anybody see the solution?
  4. ShadowMan@

    ShadowMan@ Guest

    You should study the Apache mod_rewrite docs more. The solution is:
    [b]RewriteRule  ^/silly.html$  /existing_page.html  [L][/b]
    Remember to restart the apache service.

    You do not have to run the websrvmng everytime, just after the first time the vhost.conf file is created. Restarting the apache service is required so it will re-read and reload the vhost.conf rules.