1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Webmail login problem - not "login failed"

Discussion in 'Plesk for Linux - 8.x and Older' started by kdrk1977, May 22, 2006.

  1. kdrk1977

    kdrk1977 New Pleskian

    22
    90%
    Joined:
    May 22, 2006
    Messages:
    7
    Likes Received:
    0
    Hello, I'm using PLESK 8 / CentOS 4.2, and I'm having trouble at webmail login.

    I access to http://webmail.domain and type mail address and password, load starts but when it done I'm still at the login screen.
    It doesn't show an error message, just regular login screen as if I just accessed to the page.
    However, I can check mails with mailer such as Outlook Express.

    I start having this problem since last Friday, until then I didn't have such problem.
    I checked log via SSH but I couldn't find any login error or such.

    Please help me to fix this problem!!
     
  2. kdrk1977

    kdrk1977 New Pleskian

    22
    90%
    Joined:
    May 22, 2006
    Messages:
    7
    Likes Received:
    0
    still having trouble...

    I found error message regard of this issue at /var/log/psa-horde , saying
    May 23 15:25:17 HORDE [error] [imp] FAILED LOGIN xxx.xxx.xxx.xxx to localhost:143[imap] as ???@??????.net [on line 262 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]

    I changed actual IP and domain to "x" and "?".

    I refered to other threads, checked out
    /etc/hosts and /usr/share/psa-horde/imp/config/servers.php but looks all fine..

    Please direct me if you have any ideas to fix the problem I have.
    Thank you!!
     
  3. Kanien

    Kanien Guest

    0
     
    same problem for me

    I can log in without any errors, but it just puts me back at the log in page. I need a fix for this, anyone have any ideas?
     
  4. Rouanou

    Rouanou Guest

    0
     
    I have the same problem....

    Have you found a solution ??
     
  5. Kanien

    Kanien Guest

    0
     
    sorry

    No, I updated plesk all the way to 8.0.1 and was that did not fix the error. I also tried running the websrvmng -a command in almost every other Horde problem page and that didn't work either.

    I believe it is a PHP configuration error, but I haven't figured out how to fix it yet. I will post here when I do.
     
  6. Kanien

    Kanien Guest

    0
     
    php.ini fix

    The problem is in the php.ini file, usually locted in /etc/php.ini

    It has session.auto_start = 1, which needs to be session.auto_start = 0

    It won't allow you to log in because the session is already started. 2 days of webmail down time to figure this one out. Ouch!

    BTW...make sure you restart apache 'service httpd restart' for the changes to effect.
     
  7. Rouanou

    Rouanou Guest

    0
     
    It's Ok.

    Thank you.
     
  8. jusu313

    jusu313 Guest

    0
     
    Same error here. It kicks you back to the login page. It does not do it with Squirrelmail just with Horde/IMP
     
  9. willyk@

    willyk@ Guest

    0
     
    same problem

    Hi, i have the exact same problem and cant seem to fix it, page looks fine on login then refreshes back to the login page.

    I checked my php.ini and it was fine

    session.auto_start = 0

    any ideas
     
  10. ZeroSixty

    ZeroSixty Guest

    0
     
    Also check your session.save_path

    I had this problem and found the path was incorrect
     
  11. willyk@

    willyk@ Guest

    0
     
    session_savepath

    Im running Joomla on a few of these sites and used the .htaccess file to bypass the php.ini session save path for the install. Basically i point it to a tmp directory in the website root

    Is there a file within Horde i should change to point to the same path?
     
  12. willyk@

    willyk@ Guest

    0
     
    Hi Guys,

    This was exactly what it was, my PHP.ini setting was pointing to a tmp directory that didnt exist.

    I altered my .htaccess back to use the server php.ini then created the relevant tmp directory with full write permissions and it works fine.

    Thanks
     
  13. davidgarcia

    davidgarcia New Pleskian

    22
    23%
    Joined:
    Sep 12, 2006
    Messages:
    5
    Likes Received:
    0
    Try to desactivate firewall iptables
    Try telnet localhost 143
    Is if ok and you used fedora v3 or v4, your problem is with selinux secure, selinux secure break connections socket, for resolved problem you desactive in system selinux with:

    setenforce 0

    and in boot of systen
    nano /etc/sysconfig/selinux
    SELINUX=disabled
     
  14. bVICIL

    bVICIL New Pleskian

    22
    23%
    Joined:
    Jan 29, 2007
    Messages:
    5
    Likes Received:
    0
    i did all of that but not working.

    - i edited /etc/hosts
    - i edited /etc/php.ini
    - i edited /etc/sysconfig/selinux

    but still not working.

    what must i do. waiting for reply. urgent problem...
     
  15. bVICIL

    bVICIL New Pleskian

    22
    23%
    Joined:
    Jan 29, 2007
    Messages:
    5
    Likes Received:
    0
    solved. i restart the server. and it works.
     
  16. fastcooler

    fastcooler Guest

    0
     
    This hint solved also for me! Thanks!

    Fast
     
  17. OldQuietGnome

    OldQuietGnome Guest

    0
     
    Problem is Session Related

    The problem is definitely session related.
    Double check the session save path in PHP.ini, then make sure your webserver has write access to this directory on your server.

    Example
    chown root:apache /var/lib/php/session
    chmod 775 /var/lib/php/session

    Hope this helps.
     
Loading...