1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

500 Internal Server Error

Discussion in 'Plesk 11.x for Linux' started by JonathanY, Aug 15, 2012.

  1. JonathanY

    JonathanY Guest

    0
     
    My plesk just updated automatically this morning and now I am receiving 500 Internal Server Errors on all the PHP pages.

    It also changed the directory of my where my domain is hosted. Previously the site was located at /var/www now it is located at /var/www/vhosts/domain.com/httpdocs

    I'm not sure why it updated my file path but I have tried removing the .htaccess files already.

    Any ideas on how I can troubleshoot this? Everything was working fine last night, and after update, I cannot see any PHP pages.

    If i need to check an error log, please tell me the location, because I am confused to where the logs are when trying to find them :/

    I am running plesk on debian.
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    What do you have for this:

    tail -f /var/www/vhosts/domain.com/statistics/logs/error_log

    With any of the domains displaying that error ?

    Also, may I suggest you rebuild the vhosts?

    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all

    Lastly do you have Nginx enabled or NOT?
     
  3. JonathanY

    JonathanY Guest

    0
     
    This is what is displayed from the error_log

    I rebuilt the vhosts, but no messages came up, it just waited a little and then the next line came up. Not sure if that's the way it works.

    And Nginx is disabled from the Parallels Plesk panel.
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    How about?

    tail -f /var/log/httpd/suexec_log
     
  5. JonathanY

    JonathanY Guest

    0
     
    This is what I got, I don't have a httpd folder in /log/

    :/

    I did find suexe.log in /apache2/ directory using this: tail -f /var/log/apache2/suexec.log

     
  6. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Try:

    chmod +x /var/www/cgi-bin/cgi_wrapper
     
  7. JonathanY

    JonathanY Guest

    0
     
    I did that, still the 500 error and getting the same messages regarding the cgi_wrapper in the log file.

    Edit: What are the permissions for the files and folders regarding cgi? The owners?

    Thanks.
     
    Last edited by a moderator: Aug 15, 2012
  8. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
Loading...