• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

ERROR: PleskDBException: Unable to connect to database

mdde

Regular Pleskian
Hi,
have that same stupid Error again and again.

In the Morning (always at 6:30 am) Plesk / Mysql goes down with following Error:
"ERROR: PleskDBException: Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002) (Abstract.php:69)"

What can i do?
And if i want to fix that Problem (restart Mysql, fresh install mysql) i can't get that Server running again.
Still shows me "ERROR: PleskDBException: Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002) (Abstract.php:69)"

Any Suggestions?

btw: this file /etc/my.cnf doesn't exist.
Debian 7.9 & 8.2.

Thank you.
 
hm don't looks like that Error i've mentioned. The Server is new without much customers.
Also i your Link theres Versions "Plesk 12.0" but i have 12.5
and its all sites & Plesk which isn't accessible hm.

This Solution didn't helped. Sorry.
Any Ideas?
 
Hi Daka Media KG,

try to repair your database with:

plesk repair db
... and post possible issues from the command line and/or from the repair - log.
 
Back
Top