• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Issue Error: Unable to rename home of sysuser with id...

ChrisMonder

Basic Pleskian
I got this:

1. I have domain X
2. I added a domain alias Y
3. I want to switch X for Y
4. I deleted Y domain alias in Plesk
5. I try to change domain X for Y in hosting settings and I got this:

Error: Unable to rename home of sysuser with id=XX: Unable to execute usermng: usermng[XXXXX]: pam_unix(passwd:chauthtok): password changed for XXXXXXX usermod: directory /var/www/vhosts/Y/httpdocs exists

So I look at /vhosts and no, there's no Y folder, what can I do?
 
I would suggest you check possible database inconsistencies with the following command:

# plesk repair db -n
 
Try to find this domain related errors with help of

mysql> select id,objectId,status,description from Configurations where status="error"\G;
 
Checking the Plesk database using the native database server tools .. [OK]

Checking the structure of the Plesk database ........................ [OK]

Checking the consistency of the Plesk database ...................... [OK]

Error messages: 0; Warnings: 0; Errors resolved: 0

and:

[root@svr ~]# mysql> select id,objectId,status,description from Configurations where status="error"\G;
[root@svr ~]#
 
Try to run

# plesk repair web

and then repeat your actions.
 
Back
Top