1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Installed Suitebuilder 4 but how to make it work?

Discussion in 'Sitebuilder 4.0 for Linux' started by Filipe Miranda, Oct 21, 2007.

  1. Filipe Miranda

    Filipe Miranda Guest

    0
     
    Hello,

    I installed Sitebuilder using the autoinstaller.

    Everything went successfully.

    But How do I access sitebuilder from my Plesk interface?

    I'm really new to this Plesk and Sitebuilder stuff, so could someone please help me out on this?

    Thank you,
     
  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    First of all you need to make initial configuration after Sitebuilder is installed. Suggest you to follow installation guide for this:

    http://download1.swsoft.com/SiteBuilder/4.0.0/doc/install/en_US/html/index.htm -> Configuring Sitebuilder after Installation.

    After that you need to make sure that on the Plesk server package 'psa-sbm3' installed. This package is integration module for Plesk and Sitebuilder. If you use autoinstaller you need to make sure that component "SiteBuilder and Sitebuilder module for Plesk" is installed. If you are going to publish sites on the same Plesk server do not forget to install component "SiteBuilder publishing support for Plesk".

    So when all necessary configuration is done for Sitebuilder and module for Plesk is installed you can access Sitebuilder in Plesk through Plesk admin CP -> Modules section.
     
  3. v2theg

    v2theg Guest

    0
     
    sb_config error

    I have SB4 installed using the autoinstaller, but when I run sb_config, I am getting this message.

    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.

    any ideas on what this could be?
     
  4. v2theg

    v2theg Guest

    0
     
    i just reinstalled SB Here's what the final info said.

    SiteBuilder has been installed successfully!
    Use sb_config command to configure SiteBuilder.
    'sb_config --help' displays help information.
    mysqld (pid 15552) is running...
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-areamap-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-downloadablecontent-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-eshop-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-feedback-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-flashintro-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-forum-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-guestbook-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-login-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-rssreader-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-script-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-statistics-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_module-voting-4.0.0-all.build07062700.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_de_DE-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_es_ES-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_fr_FR-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_hu_HU-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_it_IT-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_ja_JP-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_pt_BR-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_pt_PT-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_ru_RU-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_zh_CN-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    Installing the package sitebuilder_zh_TW-4.0.0-all.07070609.noarch
    Can't call method "Log" on an undefined value at /usr/local/sitebuilder/utils//SB/Utils.pm line 324.
    INIT failed--call queue aborted.
    The packages were installed successfully.
     
  5. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    2 v2theg:
    It wasn't a good idea to move you question here. Cause it's really looks like two different problems.

    As for your problem with "Can't call method "Log" on an undefined value", please contact support - https://www.swsoft.com/support/sitebuilder/form/ Investigations on the server are required.
     
  6. v2theg

    v2theg Guest

    0
     
    thanks for the note. how is it two different problems if the error message is exactly the same?
     
  7. naichunlei

    naichunlei Guest

    0
     
    I've exactly the same problem as Filipe Miranda.

    I installed SB 4.0 sucessfully on my CentOS server with PLESK but I have no idea where to access SiteBuilder from PLESK.
    I used the autoinstaller and downloaded all the sources from Plesk server.

    The instruction you gave above is making things even more confusing. I can't find any module you mentioned above anywhere.
    Do I need to download it and install it separately? Where do I download these modules?

    Here are a few more details regarding sb_config:

    sb_config --help|grep sb_host

    --sb_host_ip Create virtual host on the specified IP [72.249.28.69]

    --sb_hostname SiteBuilder virutal host name [sitebuilder.host.omonsite.com]

    Please do not point us to the installation guide or repeat the sentence on the guide because I've read it 100 times and it's simply NOT helping.

    Some screenshots might be more helpful.

    I'm almost giving up after struggling for 2 weeks.

    And there's no way I'd pay $75 a support ticket for an installation which was supposed to work!
     
  8. v2theg

    v2theg Guest

    0
     
    i heard back from support, they asked if i was running a VPS. I told them I was and they said I needed to add the IP. The terminolgy and directions they use are ridiculously vague. If this is the case, why wasn't this information in the installation guide.

    here is the link they gave me. i'm confused. not sure if this will break my current setup yet. shouldn't the command have something to do with Sitebuilder??

    wow. :confused:

    http://kb.swsoft.com/en/781
     
  9. naichunlei

    naichunlei Guest

    0
     
  10. naichunlei

    naichunlei Guest

    0
     
    What the heck is VE???:confused:
     
  11. v2theg

    v2theg Guest

    0
     
    VE is a virtual environment i think.
     
Loading...