1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Vote Please share your opinion about Plesk PHP packages

Discussion in 'Plesk 12.x for Linux' started by IgorG, Oct 20, 2015.

?

What is your overall satisfaction rating with our PHP packages?

  1. 5 - Very Satisfied

    69 vote(s)
    54.8%
  2. 4 - Somewhat Satisfied

    44 vote(s)
    34.9%
  3. 3 - Neither Satisfied Nor Dissatisfied

    9 vote(s)
    7.1%
  4. 2 - Somewhat Dissatisfied

    1 vote(s)
    0.8%
  5. 1 - Very Dissatisfied

    3 vote(s)
    2.4%
  1. Gene Steinberg

    Gene Steinberg Regular Pleskian

    25
    57%
    Joined:
    Dec 9, 2008
    Messages:
    119
    Likes Received:
    0
    I am intrigued by PHP-FPM. But your Plesk manual provides no documentation whatever beyond a basic description. Yes, I have checked the online information, and forwarded to my web guy to review.

    In my tests, it works more efficiently with PHP 5.6.x and Zend Opcache; sites seem faster.

    But I have a problem, and again my webmaster is stumped because he's not familiar with PHP-FPM.

    Here's the situation:

    We offer premium forum memberships via the XenForo Resource Manager. Our main products consist of ad free versions of my syndicated radio shows, plus extra podcasts and other content.

    To make it easier for members to listen to the radio shows on iTunes and other podcast apps, the webmaster made a special RSS feed with PHP that requires authentication to access, using member names and passwords.

    Works fine in FastCGI (and on our former cPanel server with Mod Ruid and DSO).

    But the authentication breaks with PHP-FPM. It puts up a prompt constantly asking for user password. The two domains that offer the premium memberships were reverted to FastCGI.

    I presume changes need to be made to the PHP code to allow for that to work with PHP-FPM.

    If anyone can provide guidance, let me know. I'd be happy to provide the PHP code in a private conversation to anyone who wants to diagnose.

    Thanks.

    Peace,
    Gene
     
  2. danami

    danami Regular Pleskian

    30
    18%
    Joined:
    Mar 29, 2008
    Messages:
    198
    Likes Received:
    28
    Location:
    Canada
    Just a small note that it looks like Plesks PHP 7.01 packages have a small problem by default:

    Code:
    /opt/plesk/php/7.0/bin/php -v
    
    PHP Warning:  Zend OPcache huge_code_pages: mmap(HUGETLB) failed: Cannot allocate memory (12) in Unknown on line 0
    PHP 7.0.1 (cli) (built: Dec 21 2015 15:17:03) ( NTS )
    
    You can workaround this warning by editing /opt/plesk/php/7.0/etc/php.d/10-opcache.ini and changing it to opcache.huge_code_pages=0

    I think that this is only supported in new OS like Centos 7+ should only be enabled if running a newer OS.
     
    Last edited: Dec 27, 2015
  3. Ripshod

    Ripshod Basic Pleskian

    7
    70%
    Joined:
    Sep 3, 2015
    Messages:
    31
    Likes Received:
    8
    Is this similar?
    Code:
    /opt/plesk/php/7.0/bin/php -v
    
    PHP Warning:  Zend OPcache huge_code_pages: madvise(HUGEPAGE) failed: Invalid argument (22) in Unknown on line 0
    PHP 7.0.1 (cli) (built: Dec 21 2015 15:49:09) ( NTS )
    Same workaround ;)

    On Ubuntu 14.01 LTS
     
    Last edited: Dec 27, 2015
  4. danami

    danami Regular Pleskian

    30
    18%
    Joined:
    Mar 29, 2008
    Messages:
    198
    Likes Received:
    28
    Location:
    Canada
    Yes I don't think that "Huge Pages support" made it into Ubuntu 14.01 LTS either. It needs a newer kernel/glibc. The same fix will work.
     
    Last edited: Dec 27, 2015
  5. iMadalin

    iMadalin New Pleskian

    9
    20%
    Joined:
    Apr 29, 2014
    Messages:
    24
    Likes Received:
    0
    Huge Pages need to be explicitly enabled on booting the kernel.

    Only Oracle's and RHEL distros come with enabled by default.

    Personal opinion based on many years since started using it for MySQL - huge performance boost for MySQL. Hope to see this in PHP7 as well and in the future to Redis as well.

    (Ps. Huge Pages are not for people unfamiliar with kernel internals)

    Later edit:
    • Huge table pages are for systems with large amounts of ram. The amount of ram for HTP are locked and can't be used for other processes. So on a 16GB instance you set 4GB for HTP, then you have 12GB visible and usable for the common processes. Give 3GB to MySQL and 1GB to PHP and enjoy ;)
    • Really not for WordPress or similar based websites.
    • Most of VPS providers don't enable HTP access in XEN / KVM - it must be explicitly enabled in the virtualization manager. So it is useful on dedicated.
     
    Last edited: Jan 29, 2016
  6. IgorG

    IgorG Forums Analyst Staff Member

    45
    84%
    Joined:
    Oct 27, 2009
    Messages:
    23,961
    Likes Received:
    1,093
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Please do not post technical issues here. You can create separate thread about your issue. This thread is only for sharing opinions.
     
  7. iMadalin

    iMadalin New Pleskian

    9
    20%
    Joined:
    Apr 29, 2014
    Messages:
    24
    Likes Received:
    0
    HTP is available to be enabled since Ubuntu HardyHeron (8.04 LTS - server kernel).
     
  8. iMadalin

    iMadalin New Pleskian

    9
    20%
    Joined:
    Apr 29, 2014
    Messages:
    24
    Likes Received:
    0
    Question related to current PHP 5.3 from Plesk's php packages: will it add PHP-FPM as it is supported? As we can run 5.4, 5.6, 7.0 with FPM, 5.3 would also be a benefit so it doesn't forces usage of fcgid only for a version of PHP.
     
  9. robetus

    robetus Basic Pleskian

    7
    70%
    Joined:
    Feb 27, 2016
    Messages:
    28
    Likes Received:
    0
    Multiple PHP versions is great, but version 5.4.45 doesn't work! Please fix it! I tried 5.3, 5.5, and 5.6, worked great, but 5.4 gives a fastCGI error. I'll post a separate message about this also.
     
  10. 9musashi

    9musashi Basic Pleskian

    6
    20%
    Joined:
    May 2, 2016
    Messages:
    39
    Likes Received:
    3
    As a new Plesk user, I was surprised by how good Plesk PHP package is. I even drop & uninstall PHP selector from CloudLinux and only use Plesk's multiple PHP version.
     
    Lloyd_mcse and trialotto like this.
  11. trialotto

    trialotto Golden Pleskian Plesk Guru

    35
     
    Joined:
    Sep 28, 2009
    Messages:
    1,348
    Likes Received:
    188
    @Sennan,

    Nice to hear that!

    I am glad to see that you are content with the Plesk PHP packages, this in contrast to the "doom and gloom" messages some people tend to post.

    A small tip: just keep the PHP configuration as standard as possible, the default PHP packages are in most cases sufficient.

    If you have some questions about those PHP packages and/or extensions for them, just start a conversation with me or post a question on the forum!

    Regards.....
     
  12. Miguel_Tellería

    Miguel_Tellería Basic Pleskian

    6
    20%
    Joined:
    May 26, 2015
    Messages:
    37
    Likes Received:
    1
    Hello Plesk team,

    I am also having an issue with Xcache in plesk-php55-fpm:

    I know and I understand why it is disabled, but I still see in our subscriptions (originating in a 12.0.18 server migration) that in the conf files of /opt/plesk/php/5.5/etc/php-fpm.d/<domain>.conf the following lines:

    php_value[xcache.cacher] = on (also present in the final php.ini file in /var/www/vhosts/system/<domain>/etc/php.ini.

    As a result we have a flood of error messages in /var/log/plesk-php55-fpm/error.log.

    Since both the conf file and the ini file are generated by Plesk I still don't know how can I remove that line in a permanent way. PHP options in "tools and settings" or in "sites and domains" don't show (or at least I don't see) a place to deactivate this setting.
     
  13. trialotto

    trialotto Golden Pleskian Plesk Guru

    35
     
    Joined:
    Sep 28, 2009
    Messages:
    1,348
    Likes Received:
    188
    @Miguel_Tellería

    The term "xcache" should not be present in any php.ini file, at least not in those ini files provided with and/or generated by Plesk.

    I would suggest that you have a look at manual customizations, even though automatic customizations can also be the cause of the changes in the ini files.

    You can consider to take the following actions:

    a) if it is a custom PHP 5.5 package, just

    - switch to PHP 5.6 by installing PHP 5.6 and removing PHP 5.5 (via the autoinstaller preferably), OR
    - re-install the PHP 5.5 package (this would often cleanup all installation files properly; it is also a nice method to test whether automatic customization are applied afterwards)

    and be sure that you, before doing any of the above, check and verify (!) that you have all the latest micro-updates applied.

    b) if it is the OS Vendor package that you are talking about, just

    - unload the xcache module ("comment" the line containing extension=..., or remove the xcache related ini file from /opt/plesk/php/5.5/etc/php.d/)
    - cleanup all ini and config files containing or involving xcache

    and the above really is a very rough outline.

    I hope that the above helps a bit.

    Regards..
     
  14. Miguel_Tellería

    Miguel_Tellería Basic Pleskian

    6
    20%
    Joined:
    May 26, 2015
    Messages:
    37
    Likes Received:
    1
    Thanks @trialotto for your quick reply. I will try the b) path and will post again if I have other trouble.

    I didn't said it before, but I thank Plesk for maintaining their PHP packages and save us time and troubles at work.
     
  15. trialotto

    trialotto Golden Pleskian Plesk Guru

    35
     
    Joined:
    Sep 28, 2009
    Messages:
    1,348
    Likes Received:
    188
    @Miguel_Tellería

    By the way, it is not "that bad" to have XCache, with the degree of "bad" more or less depending on the OS you are running.

    It can be the case that you have some php code related errors in your log files, with those errors being unrelated to XCache (and the proper working thereof) itself.

    In short, you can (on the one hand) disable XCache (with the danger that the root cause of the problem, resulting in errors in the log files, will remain present) and (on the other hand) do some thorough investigation with respect to the errors you found in the log files.

    In my humble opinion, the most convenient way is to disable XCache and have a look at the (new) results, with or without some caching mechanism.

    Regards.......
     
  16. Powerdynamo

    Powerdynamo New Pleskian

    2
    70%
    Joined:
    Feb 1, 2016
    Messages:
    20
    Likes Received:
    0
    i keep having trouble with supplied 5.) FPM after plesk updates. today again.
    lower versions with fast cgi are more stable. for me anyway they always cured the problem FPM did create.
    edgae
     
  17. dalkol

    dalkol New Pleskian

    14
    35%
    Joined:
    Jun 9, 2011
    Messages:
    18
    Likes Received:
    0
    After latest update of plesk, my websites is crashed , php and ajax scripts is dead... :(
     
  18. dalkol

    dalkol New Pleskian

    14
    35%
    Joined:
    Jun 9, 2011
    Messages:
    18
    Likes Received:
    0
    Tried to switch to another version of php, no changes :(
     
  19. Dx3webs

    Dx3webs Basic Pleskian

    20
    23%
    Joined:
    Oct 11, 2010
    Messages:
    78
    Likes Received:
    1
    Run these command

    /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components
    /usr/local/psa/admin/sbin/nginxmng -d
    /usr/local/psa/admin/sbin/nginxmng -e

    they fix most of these types of problems
     
  20. dalkol

    dalkol New Pleskian

    14
    35%
    Joined:
    Jun 9, 2011
    Messages:
    18
    Likes Received:
    0
    Thanks, you mean for php ?
     
Loading...