1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk partially removed after MU

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by CoenNL, Jul 16, 2012.

  1. CoenNL

    CoenNL Guest

    0
     
    We've tried to update Plesk 10.4.4 (Ubuntu 10.04 LTS) to MU39 on several servers via the autoinstaller. We've used the same steps before to update those servers to MU36.

    On some servers Apache failed to start after this upgrade; libapache2-mod-php5 was removed in addition to the Plesk installation itself.

    After verifying the logs we found the following:

    --
    The following packages will be REMOVED:
    apache2-mpm-prefork* libapache2-mod-php5* plesk-core* plesk-l10n* pp-sitebuilder* psa* psa-backup-manager* psa-health-monitor* psa-horde* psa-imp* psa-ingo* psa-kronolith* psa-libxml-proxy* psa-migration-agents* psa-migration-manager* psa-mimp* psa-mnemo* psa-passwd* psa-php5-configurator* psa-turba* psa-updates* psa-vhost*

    The following NEW packages will be installed:
    apache2-mpm-worker
    --

    Another server, which had autoupdates enabled, also had the same problems.

    Anyone here who had the same issues?
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Looks like in your process it un-installs php.
    Anyways as a quick workaround just from your SHELL run the command

    /usr/local/psa/admin/sbin/autoinstaller

    and follow the instructions to install all missing components.
     
  3. CoenNL

    CoenNL Guest

    0
     
    Not only PHP but it deleted the plesk-core also. We did fix it by 'reinstalling' those components but I would like to know the cause, because these servers were updated to MU36 the same way without any problems. And this is an automated process. Parallels?
     
  4. NomanD

    NomanD Guest

    0
     
    Even when i run the autoinstaller again it fails with the error libapache2-mod-php5 at the beginning,

    Is there any solution for this?
     
  5. Nikolay.

    Nikolay. Silver Pleskian

    17
    35%
    Joined:
    Jul 1, 2012
    Messages:
    844
    Likes Received:
    2
    This is due to a bug in APT.

    Plesk 11.0.9 should have a workaround for it. You may want to just upgrade to it.

    If you don't want to upgrade, you may try following (I have not tested this and I'm not sure it will work, but in theory it should):
    1) Remove apache2 package (IIRC, on Ubuntu this will not require removal of any other packages): # apt-get remove apache2
    2) Download Autoinstaller version for Plesk 11.
    3) Run it via: # ./autoinstaller --all-versions
    4) Try to upgrade your 10.4.4 installation as you would normally.


    [Edit] Easier and more reliable steps would be (to ensure Autoinstaller would not remove half of your Plesk installation):
    1) # apt-get install apache2 apache2-mpm-prefork
    (if you have another flavour of apache2 installed, you should replace last package name accordingly)
    Essentially, via this step you should make sure that you have latest Apache version installed.
    2) Run your Autoinstaller as you normally would.
     
    Last edited: Jul 24, 2012
  6. NomanD

    NomanD Guest

    0
     
    Here are the error details:
    The following packages have unmet dependencies:
    php5 : Depends: libapache2-mod-php5 (>= 5.3.10-1ubuntu3.2) but it is not going to be installed or
    libapache2-mod-php5filter (>= 5.3.10-1ubuntu3.2) but it is not going to be installed or
    php5-cgi (>= 5.3.10-1ubuntu3.2) but 5.2.10.dfsg.1-2ubuntu6 is to be installed or
    php5-fpm (>= 5.3.10-1ubuntu3.2) but it is not going to be installed
    Depends: php5-common (>= 5.3.10-1ubuntu3.2) but 5.2.10.dfsg.1-2ubuntu6 is to be installed
    psa-php5-configurator : Depends: php5-ioncube-loader (>= 4.0.14) but 4.0.7-11051008 is to be installed
    Depends: libapache2-mod-php5 but it is not going to be installed

    ---------------------- `apt-get` output ---X---
    Collecting error details into log file...
    Error: Installation will not continue
    Not all packages were installed.
    Please, contact product technical support.

    BTW, uninstalling apache2 is it going to remove my hosting websites?
     
  7. NomanD

    NomanD Guest

    0
     
    After continues working i was able to install plesk (partially) as i ended with the following error

    Errors were encountered while processing:
    bind9
    plesk-core
    plesk-l10n
    pp-sitebuilder
    psa-vhost
    psa
    psa-libxml-proxy
    psa-backup-manager
    psa-horde
    psa-imp
    psa-ingo
    psa-kronolith
    psa-mimp
    psa-mnemo
    psa-passwd
    psa-turba
    psa-updates
     
  8. schlimpf

    schlimpf Basic Pleskian

    11
    85%
    Joined:
    Jul 25, 2012
    Messages:
    37
    Likes Received:
    0
    I had a similar Problem. After the automatic microupdate #36 the Plesk core was removed. OS is Ubuntu 10.04 LTS. I had to reinstall Plesk via the autoinstaller. Fortunately all settings were still present. Is this a known issue?
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  10. schlimpf

    schlimpf Basic Pleskian

    11
    85%
    Joined:
    Jul 25, 2012
    Messages:
    37
    Likes Received:
    0
    Thank you for the information
     
Loading...