1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

plesk seems to be confused

Discussion in 'Plesk for Linux - 8.x and Older' started by k.satirli, Jan 10, 2006.

  1. k.satirli

    k.satirli Guest

    0
     
    I ran some upgrades lately and it all seemed to work fine - turns out now that it didnt.

    I tried to login via SSH today and while I can get to the Shell, I can't use SFTP anymore.

    I also can't switch to root (by using "su -") from the privileged account that is allowed to login as root - it seems that the wheelgroup has been modified by Plesk and didn't get changed correctly.

    Plesk also complains that nothing is installed (see attached screenshot) and the module manager (which I turned off now) went nuts telling me that apache wasn't running - while it actually worked perfectly.

    another downside: webmin doesnt work anymore since the admin account got ... well ... disabled / rewritten / set to non active - I dunno.

    [EDIT]

    when I tried sudo I got this:

    Code:
    sudo: can't stat /etc/sudoers: Input/output error
    
    and su gives me

    Code:
    -bash-2.05b$ su -
    su: ungültiges Kennwort
    which translates into: "incorrect password"

    normally when I enter "su -" I get asked for a password, not so today though.

    any thoughts on how I could ge this one figured out?
     
  2. spandox

    spandox Guest

    0
     
    hack root and change the root password. If you have physical access to the box this is trivial.
     
  3. k.satirli

    k.satirli Guest

    0
     
    I do have serial access, which I guess would work, but my guess is that the passwd file got screwed.

    the only privileged user is not allowed to login anymore (odd enough) and the user "admin" (which I thought plesk used) doesnt exist, according to the server.

    thoughts?
     
  4. spandox

    spandox Guest

    0
     
    THIS IS WAY OFF THE PLESK PLAN:

    reboot into single user mode (if you don't know how to do this google it)

    type passwd root

    change your root password
    reboot with 'reboot'
     
  5. k.satirli

    k.satirli Guest

    0
     
    thanks for the help - I realized that is was off the plesk plan but I guessed that plesk screwed up the passwd file - cause I get a mail every time someone logs in with root - and the only login I got was from my IP.

    and I'm puzzled as to why plesk doesnt show anything

    screenshot --> here
     
  6. k.satirli

    k.satirli Guest

    0
     
    I just was reading thru my suse linux manual (printed edition) but I'm guessing that its the same for Fedora (which I'm running).

    the manual says that "booting into single user mode cant be done remotely" and that I need to be at the physical location - which is gonna be a problem, since I'm guessing that my hoster wont grant me access to the DC.

    they however offer a serial console, which according to their site is like sitting in front of the terminal.

    any idea if that would work?

    and why does plesk say nothing is installed?
     
Loading...