1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

qmail / email quick to send slow to recieve

Discussion in 'Plesk for Linux - 8.x and Older' started by Inner Child 77, Aug 10, 2005.

  1. Inner Child 77

    Inner Child 77 Guest

    Hello I have been having some issues with email. Basically what has happened is my ISP changed IP addresses and things where really bad (no email at all) now things seem to be fine (everything resolving) but I have dome everything I can ssem to find on the forum. Nothing is getting any wore but not any better either. I have listed below some of the tings I have done and some information that might start us out right.



    server_args = -Rt0 /var/qmail/bin/relaylock
    restart xinetd

    Nothing in the queue
    not a spam load

    smtp_psa file
    service smtp
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0/usr/sbin/rblsmtpd -r bl.spamcop.net -r sbl-xbl.spamhaus.org
    -r opm.blitzed.org -r dnsbl-1.uceprotect.net -r china.blackholes.us -r hongkong.blackholes.us
    -r korea.blackholes.us -r taiwan.blackholes.us -r brazil.blackholes.us
    -r wanadoo-fr.blackholes.us -r chinanet.blackholes.us
    -r cn-kr.blackholes.us /var/qmail/bin/relaylock
    /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth
    /var/qmail/bin/true /var/qmail/bin/cmd5checkpw

    nameserver 111.222.333.44
    search localdomain (it actually has the text localdomain with red background)resolv.conf
  2. Inner Child 77

    Inner Child 77 Guest

    Sorry one thing I should clarify is that I am using Outlook to send recieve my email and if I restart qmail I'll get the Outlook test email within a few minutes. But others in the ofice are using MAC's and it had been hours and nothing from them.


  3. Inner Child 77

    Inner Child 77 Guest

    Also if I do a DNS report there is no connection to the mail server but email still works...kinda. I just found out some emails seem to be dropping off the map.
  4. jamesyeeoc

    jamesyeeoc Guest

    2 things to try:

    1) Put a space after the -Rt0

    2) Try cutting down on how many RBLs you are using. The more you put in the list, the longer the delay can be. If you do a test with no RBLs and there is still the same amount of delay, then it rules out the large number of RBLs as a source of delay.

    This part of your post shows no space after the -Rt0
  5. Inner Child 77

    Inner Child 77 Guest

    Hey James thanks for EVERYTHING. Now what I did is the following.

    Added space restarted qmail (I send one just before this) and it took about 10min

    Disabled MAPS restarted qmail, still haven't recieved email from above.

    All catch accounts have been disabled.

    So one other thing I did was in Outlook was set the outgoing server to mine and things were good but the email wasn't sent. The error was we can find the server but there is no response.

    One other thing I check DNS report, and I know it is not the best tool to use. But it seems to be having troubles connecting to the mail server. Can you do any test from your end to let me know if something is off? There has been no DNS change but with the email acting funny and that showing up I want to make sure.

    What else can I try?

  6. Inner Child 77

    Inner Child 77 Guest

    THe other thing I noticed is that /var/log/messages
    is 5 days old? not sure if that is an issue or not.
  7. Inner Child 77

    Inner Child 77 Guest

    Figures, so now the mail server seems to resolve, I am getting "you don't have abuse or postmaster accounts" But I don't think that should be a issue.
  8. jamesyeeoc

    jamesyeeoc Guest

    Not having 'abuse' or 'postmaster' would not cause this.

    If the logs are 5 days old and you are getting 'we can find the server but there is no response', then have you made sure your firewall is not blocking connections and try telnetting to your server on port 25 from a workstation on a different ISP than your server:

    telnet domain.com 25

    and see if you get a connection.

    On the server, from a shell prompt via SSH, you can also see if there is anything 'listening' on port 25

    netstat -an |grep ':25'

    If there is nothing listening on port 25, then that would be a problem.

    If there is and you disable the firewall (just as a test) and still cannot get a connection using Telnet, then there is some other probably network or DNS problem.
  9. Inner Child 77

    Inner Child 77 Guest

    James it turns out a angry phone call to the ISP was the answer. About 1 hour after I did that there dosen't seem to be a problem with lag anymore. Thanks for all the help though. I am sure my server is working better.


  10. jamesyeeoc

    jamesyeeoc Guest

    Glad to hear it's working better. But if you could find out what they did to fix it, it may be helpful for other people searching the forums in the future.