• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Issue This update addresses a critical security issue. We strongly recommend that you apply it as soon as possible.

Azurel

Silver Pleskian
Server operating system version
AlmaLinux 8.10
Plesk version and microupdate number
18.0.74#2
In Changelog I found this
This update addresses a critical security issue. We strongly recommend that you apply it as soon as possible.
for Plesk Obsidian 18.0.74 Update 2 and Plesk Obsidian 18.0.73 Update 5.

If this is so very important, why is no corresponding notification sent to the admin account by email? I receive an email when an update has been installed automatically, but not when urgent action is required? Or has anyone received such a notice?
 
What is the actual security issue ??

And no for security issues Plesk should do a better job of notifying owners of licenses.

Ladylinux
 
I’ve shared a suggestion regarding this issue in the Plesk Suggestions and Feedback forum for Plesk to improve security notifications:

 
Hi,

I would edit but you only give people a few minutes to edit or delete

Unbelievable this is a ROOT level Vulnerability!!!

This is the actual vulnerability


https://support.plesk.com/hc/en-us/...s-to-execute-arbitrary-code-on-behalf-of-root

And



No where is it even clearly shown that this affects earlier Plesk Versions and those just have clunky workarounds!!

Unacceptable Plesk!!
 
It would be really helpful if security advisories clarified whether an issue can be exploited remotely by an unauthenticated visitor or requires existing access to Plesk (e.g., as a customer or admin).

I don't have any customers or additional admins, yet these critical security warnings always put me on high alert, only to find out weeks later that the vulnerability required authenticated access. A little more transparency about the actual risk would be greatly appreciated!
 
I'm a bit confused by your response. You're referencing articles published approximately 11 months ago.

Are you suggesting that Plesk has only now released a patch for a vulnerability that has been publicly documented on its own website for nearly a year?

If so, could you please clarify why the vulnerability remained unpatched for that length of time, or whether the recently released update addresses a different issue?
 
@nmdpa3 I think there’s just a timing mix-up here. The two articles Ladylinux linked (CVE-2025-66430 and CVE-2025-66431) were published in December 2025, right when this thread started, and they belong to exactly the update Azurel asked about (18.0.74 Update 2 / 18.0.73 Update 5). Both articles list 18.0.73.5 and 18.0.74.2 as the fixed versions, so the vulnerabilities were not left unpatched for a year.

@Azurel you’re right about the exposure. Both are local privilege escalations: an attacker needs a logged-in Plesk user account (for CVE-2025-66431 even with specific permissions like site and domain management). If you run a server without customers or additional admins, that attack path essentially doesn’t exist for you. Updating is still the right call, but no reason for panic.

@Ladylinux fair point that older versions are less convenient: for 18.0.72 and earlier, the articles only offer an upgrade to the next release or a manual patch/workaround.

What does remain a legitimate criticism is the communication. “Critical security issue” without CVE, component or required privileges is hard to assess when the details only show up later on the support site. Maarten’s suggestion for proper advisories deserves an upvote. ;)

Regards
Tessa
 
Back
Top