• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

upgrade

P

p0l0mint

Guest
I have an outdated version of plesk, 8.6.0. The updater section of plesk, in my control panel, had a list of release names up until version 10.2.0 that I could choose from and I chose release 10.2.0. I selected this release to update my existing version.

I received two confirmation emails, one said that the panel failed to update, the other said the panel was successfully updated.

In the email that reported that the panel failed to update, I received information like:

Try to find rcfile...
Autoinstaller rcfile not found.
Unable to process patch config: PSA_10.2.0/plesk-patches-10.2.0-cos4.2-i386.inf3: Failed to parse the patch file at (line 749 column 9) Unsupported item type: shell (line 749 column 9)
autoinstaller: Error in execution of /root/psa/PSA_10.2.0/plesk_getkeyinfo.sh
Not all packages were installed.


The email which reported successful installation reported the following:

Try to find rcfile...
Autoinstaller rcfile not found.
Unable to process patch config: PSA_10.2.0/plesk-patches-10.2.0-cos4.2-i386.inf3: Failed to parse the patch file at (line 749 column 9) Unsupported item type: shell (line 749 column 9)
File downloading PSA_10.2.0/dist-rpm-CentOS-4.2-i386/opt/updater/psa-autoinstaller-3.9.0-110316.15.i386.rpm: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
Starting installation of packages
Warning: unresolved requires '/usr/bin/lp' from redhat-lsb-3.0-8.EL.i386
Warning: unresolved requires '/usr/bin/lpr' from redhat-lsb-3.0-8.EL.i386
Warning: unresolved requires '/usr/sbin/sendmail' from redhat-lsb-3.0-8.EL.i386 Installing the package psa-autoinstaller-3.9.0-110316.15.i386
The packages were installed successfully.



Both emails reported that all the files downloaded successfully.


In the 'My desktop' section, the version hasn't changed, it has remained 8.6.0

Shall I assume that nothing has been installed if the version number is the same?

Should I have upgraded plesk one release number at a time?

How do I check to see if anything was installed?


Thanks for your help!
 
If you have shell access, may I suggest you upgrade through SHELL by running the autoinstaller eg

/usr/local/psa/admin/sbin/autoinstaller
 
Back
Top