Issue Your message could not be sent. The user %user% is not allowed to send email

Discussion in 'Plesk Onyx' started by SubPixel, Mar 15, 2017.

  1. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    Hi all,

    i'm running Plesk Onyx version 17.0.17 Update 18

    I've tried using both Postfix and Qmail, Dovecot and Courier.
    When i keep the outgoing email limits enabled, no one user is able to send emails using php_mail().

    The message i have in mail log is:
    Your message could not be sent. The user %user% is not allowed to send email.
    (where %user% is the Subscription username)

    I'm going to post asap the log, i can't access my server atm.
    Does any one had this issue?

    Regards,
    Pietro.
     
  2. IgorG

    IgorG Forums Analyst Plesk Team

    37
     
    Messages:
    22,649
    Likes Received:
    675
    Trophy Points:
    882
    Location:
    Novosibirsk, Russia
    Looks like that %user% reached outgoing email limit. Have you checked it?

    Also you can add %user% to whitelist using the command below:

    # /usr/local/psa/admin/sbin/mailmng-outgoing --add-to-whitelist --sysuser=username
     
  3. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    Hi, Plesk tells me that no use reached the limit.. How can i check the single user using command line?
    Already tried with the white list, nothing changes.

    Yesterday i found in the log that "psa-courier-imap-xxx" was missing, tried installing it, tried moving to Dovecot, tried back to Courier, no error messages for component not found but email not going out for the same reason (limits)..
     
  4. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    as you can see more users have the same problem..
     
  5. IgorG

    IgorG Forums Analyst Plesk Team

    37
     
    Messages:
    22,649
    Likes Received:
    675
    Trophy Points:
    882
    Location:
    Novosibirsk, Russia
    Try to disable outgoing email limit. Will it work as expected?
     
  6. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    As i said in my first post:
    if i disable the limits all the emails start working
     
  7. IgorG

    IgorG Forums Analyst Plesk Team

    37
     
    Messages:
    22,649
    Likes Received:
    675
    Trophy Points:
    882
    Location:
    Novosibirsk, Russia
    Do you have Allow users and scripts to use Sendmail option enabled in Tools & Settings > Mail Server Settings ?
     
  8. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    Yes, i have. I tried disabling it, send an email, enable again, try again to send but nothing, same error.
     
  9. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
    Checking the outgoing monitor of the users from the log they are all as the following screenshots.
    No limit reached...
    [​IMG]
    [​IMG]
     
  10. SubPixel

    SubPixel New Pleskian

    1
    70%
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    Brescia, Italy
Loading...