1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.01 latest update FTP backup returns - but doesn't work :(

Discussion in 'Plesk for Linux - 8.x and Older' started by 105547111, Jul 15, 2006.

  1. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I just checked and there were updates, particularily the backup module!

    So I installed them.

    Now I have a FTP Account Properties in backup!

    I fire away and put in the details. I check its working by mistyping a userid/pass and then a non existant directory - any YES that part works!

    I then schedule a backup AND

    nothing :(

    If I manually run the backup to the FTP server it works.

    So we are close....

    Also I just tried scheduling a backup to be written locally, it also does NOT get written. Seesm there is some issues with the schedules actually getting done :(
     
  2. jwdick

    jwdick Guest

    0
     
    I installed this update yesterday. A scheduled backup to the ftp server runs, but does not show up in the plesk list. Manually ftp to the backup server and the backup files are there.

    Another problem I ran into was that I had three domains scheduled to store files locally. Everything worked until I did the upgrade. The FTP upgrade broke the store locally backups in that I get an error message emailed to me that says:

    That plus the local backup runs every 15 minutes. The backup works storing locally but plesk doesn't know it and continues trying. I had 15 backups from just today on each of these three domains before I caught what was going on.

    Had to disable all scheduled backups and return to my backup script.

    If you haven't updated, you may not want to just yet...
     
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Jack,

    That is easily fixed. Simply just look at all your schedules and just click OK.

    It resaves them and stops the 15 minute updates.

    But it then seems to stop completely...

    I just rebooted the server and set up a schedule the top of the hour, I will post if it works or not...

    But go ahead and simply OK all your schedules that will stop the constant updates.

    - Update - nope it didn't do a thing. No email of an error and not a file on the ftp other than my manually ran ones :(
     
  4. RuthServer

    RuthServer Guest

    0
     
    which linux do you have?
     
  5. k.satirli

    k.satirli Guest

    0
     
    having the same problem here.

    my normal backup runs at 3:25 am for the one domain that was affected and it was at the correct size (around 330megs), then suddenly, 15 mins later it runs again and the backup is 660 megs in size.

    all following backups were also 660megs in size - it continued from 3:40am till about 11am and I had to delete quite a few backups - something around 20 gigs.

    also got the mail about "cant resolve host ftp".

    Stay away from this for now, if you can.
     
  6. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Ruthserver I am running FC4 fully updated.
     
  7. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    liquidblaze,

    The can't resolve hostname error is you don't have any info in the FTP tab..

    If you also re-select your schedules as I had mentioned it not only stops the 15 minute error it selects local properly so you don't get the FTP host error.

    Its obvious this error is being caused as now with FTP support there is a extra option to select FTP or local for the dumps.

    As configurations are previously made without the extra field there is no way to avoid the error, unless you just re-select and OK your scheduled backup, simply saving the configuration file correctly to match the new backup facility.
     
  8. k.satirli

    k.satirli Guest

    0
     
    sorry - it was still early for me when i posted it.

    must have missed that part - thanks for the heads up though :)

    so basically ftp transfer will also work?
     
  9. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Yes everything works!

    I had one issue I set a schedule and nothing happened.

    Seems there is a small bug. Once you set the scheduled time (ftp or local) and hit okay, when the time comes nothing happens.

    Its to do with the date. The day you set the schedule the backup utility ignores that day (so even if its say 10am and you set 10PM)

    But 24 hours (+1 day) the difference it runs on and on (unless you go back into schedules and ok it again).

    So as long as your aware there is a 24 hour (+1 day) and the time difference you set it works perfectly.

    My FTP backup server is having the files written for all the domains I left the settings alone with.

    The issue with it ignoring 'today' and not running until the next day will be looked at for the next hotfix.

    But YES it works perfectly as long as your aware of this limitation.
     
  10. jwdick

    jwdick Guest

    0
     
    Are you ftp backup files being listed in the index so that you can restore them? In Plesk 7.5.4, there was a ftp upload button but I do not have that button in 8.01 so I do not have a list of backup files.
     
  11. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    If you have the latest updates for 8.01, in backup you will now have 4 tabs....

    From left to right

    backup now
    scheduled backup
    ftp account properties
    refresh

    The files get written (if you select ftp) straight to your ftp backup, they don't show up in plesk at all.

    Maybe a suggestion for the future would be some sort of FTP retrieval from your FTP backup.

    Right now if you wanted to restore you would have to via shell log into your FTP backup and transfer the file(s) you wanted into:

    /var/lib/psa/dumps/1/

    You can find from there the exact path by creating a local backup and finding the subdirectory in there.

    It works I have done it before, but yes adding a FTP retrieve backup would be a great feature!
     
  12. PE-Steve

    PE-Steve Guest

    0
     
    Cool, I'm supposed to go through literally HUNDREDS of accounts on this server and click the 'OK' button, to fix something that SWSoft screwed up again? Come on, do they seriously not test anything?

    "Oh, hey, we just added this FTP backup thing, hopefully it works and doesn't screw up anyone's scheduled backups! People are going to be so happy!!!"

    WRONG.
     
  13. RuthServer

    RuthServer Guest

    0
     
    hi,

    if i have already set my backup-time and do now install this update and do nothing else...... is there this bug too?
     
  14. 0031

    0031 Guest

    0
     
    You may download backup file from FTP server using just a browser. And you can upload backup file to local Plesk backup repository from Plesk GUI through "Add New File" button.

    BTW I've tried hard to reproduce this bug with upgrade 8.0.0 -> 8.0.1 and obtain this "Couldn't resolve host 'ftp:'", but didn't succeed. Can somebody contact Plesk support regarding this problem?
     
  15. RuthServer

    RuthServer Guest

    0
     
    uahhhh...... :( :( ... i installed the update yesterday too and have the same BUG! (Suse 10.0) thx for the info with "ok-button" i hope this works. @Plesk_team: You ought to be ashamed of yourself!!!

    *Edit*
    scheduled backup doesn´t work... nothing happen
     
  16. bhelmick

    bhelmick Guest

    0
     
    Problem occurs here with the same circumstances. It has occurred for the past three days straight. On the first day I did what was suggested in this thread and clicked OK on each domain to reaffirm the "local repository" setting. That did not help. The second day I went through and disabled and re-enabled each domain. That did not work. As a test I set one of my domains to backup via an FTP loopback and that worked. So this morning when all of the domains failed again (except that one) I set them all up this way. Keep in mind each time it failed I had to remove its backup retrys which it makes every 15 minutes! I had nearly 50gigs of backups! Thank goodness I had a large enough drive or Plesk would have eaten my server.

    More specifically here is what I did to work around this problem until Plesk can fix this. I created a local user with a home directory the same as Plesk’s backup location. I then set the domain to backup though FTP using itself as the hostname. So in essence, it’s backing up to itself using FTP. That’s absolutely retarded, but it has worked for me so far.

    I really hope Plesk fixes this soon, I’m getting very tired of spending 30 minutes each morning cleaning out files from my server’s hard drive.
     
  17. kastorff

    kastorff Guest

    0
     
    I'm having similar issues. I had a previously working local backup scheduled. After the upgrade, I get the FTP errors, even though I don't have the FTP option checked. I don't want to enter FTP information or use the FTP backup option. I have another method to store backups remotely. Also Plesk no longer enforces the retention policy; it never removes the oldest backup. It also goes into a backup loop...in my case every 30 minutes.

    SWsoft must have the worst QC/testing department I've ever seen.

    Using SuSE 9.3...
     
  18. k.satirli

    k.satirli Guest

    0
     
    same problem here. even after disabling the automated backup, plesk continued to make backups every 15 mins (on some domains) and every 30 (on a few other domains).

    quite annoying to wake up and have to clean up 40 gigs of backup - im thankful for big HDDs ...

    I'm not sure if they do any QA at all - I mean how could someone not notice this?

    then again, they have a quite big userbase for testing ... "us". and even though im not selling hosting, it annoys me to no end that software I paid for isnt working.

    - FC4 64bit
     
  19. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    AGGGGG How do we stop the backups?

    I have turned scheduled backups off but they are still happening.
     
  20. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Pleask say...

    "Actually it is known issue and should be fixed in nearest Plesk 8.1 release which will be available at the end of August."
     
Loading...