• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Daily Cron Error: run-parts /etc/cron.daily

B

Basscar

Guest
Every day I receive this error message:

/etc/cron.daily/logrotate:

error: logrotation:1 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:2 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:3 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:4 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:5 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:6 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:7 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:8 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:9 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:10 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:11 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:12 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:13 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:14 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:15 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:16 unknown option 'Ni' -- ignoring line
error: logrotation:16 unexpected text
error: logrotation:17 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:18 lines must begin with a keyword or a filename (possibly in double quotes)
error: logrotation:19 unknown option 'KIO' -- ignoring line
error: logrotation:19 unexpected text
error: logrotation:20 lines must begin with a keyword or a filename (possibly in double quotes)


It has given me the errror when upgrading to version 10.4.4
 
I get the same thing.

/etc/cron.daily/logrotate:

error: temp:1 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:2 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:3 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:4 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:5 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:6 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:7 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:8 lines must begin with a keyword or a filename (possibly in double quotes)
error: temp:9 lines must begin with a keyword or a filename (possibly in double quotes)

I will try to remember to post here if I find a fix in the meantime.
 
Likely Solution To Daily Cron Error: run-parts /etc/cron.daily

I discovered a file titled "temp" that contained a standard 404 error html page in the directory /etc/logrotate.d

This file has 9 lines of html, exactly the number of errors I am seeing, and html doesn't fit the config parameters for logrotate, so the errors make sense. I removed the file. I expect to see the errors no longer. :)

I'd suggest looking in that directory and checking all of the files. The list of files now in my directory are:

exim httpd iscsiuiolog mailman named nginx rpm samba sa-update snmpd syslog temp yum

Art
 
Last edited by a moderator:
Amazing!

Thank you so much! Getting rid of those html lines finally fixed it! You sir are my hero.
 
Back
Top