1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR: PleskFatalException

Discussion in 'Plesk for Linux - 8.x and Older' started by omid, Sep 25, 2007.

  1. omid

    omid Guest

    0
     
    :mad: hi
    today i upgrade my plesk 8.1.1 to 8.2.1.
    and advise you never do that.
    after upgrade i recevied an email show success and after one anotehr email show failer.
    now plesk is down and show this messege:

    ERROR: PleskFatalException
    Components::componentUpdate() failed: Unable to exec utility packagemng: packagemng: Error: HTTPD_SERVICE not defined
    0: /usr/local/psa/admin/auto_prepend/auth.php3:484

    unfortunately i didn't have any backup.
    website is working but emails not.
    may any one help me very soon?
    can i restore to 8.1.1 by cancelling this upgrade ?
    help me
    thank u.
    yahoo id: r_omid2000
     
  2. umgdesigns

    umgdesigns Guest

    0
     
    Hey, I have the exact[/] same issue. I am running PHP4 on a server with SUSE 9.3 (64bit). The server is from 1and1.

    I tried restoring the PHP.ini file from the backup Plesk created during the hosing of the installation. That didn't do me any good.

    You can see my error here:https://74.208.8.164:8443/

    It seems to be related to the message 0: /usr/local/psa/admin/auto_prepend/auth.php3:484.

    I found the file at the said location. There were no backups of it. I am going to try to locate the file in the package for distro and copy it to the same location.

    I will let you know what happens. I am sure others are experiencing this too.
     
  3. omid

    omid Guest

    0
     
    my admin changes the config file of plesk at /etc/psa/
    but i dont know what he do exactly
    and after that i upgarde and this time it is ok
     
  4. ideasmultiples

    ideasmultiples Basic Pleskian

    25
    73%
    Joined:
    May 19, 2004
    Messages:
    83
    Likes Received:
    0
    Use /usr/local/psa/bin/autoinstaller from ssh to test upgrades
     
  5. umgdesigns

    umgdesigns Guest

    0
     
    Any way you could find out what was changed in the config file? I tried restoring the backup config file, but no luck.
     
  6. omid

    omid Guest

    0
     
    he just tell me changed in config file and say after upgrade the address of something was changed and he change it again. after that u have to upgrade ur plesk.my plesk after the first upgrade loss a lot of its program. like firewal and whatdogs and ability to create db o open db admin.
     
  7. umgdesigns

    umgdesigns Guest

    0
     
    Ok, I'm not so sure this is the same issue.
     
  8. umgdesigns

    umgdesigns Guest

    0
     
    Issue Resolved

    First I opened the config file:

    etc/psa/psa.conf

    I added the line (as it was missing, so sayed the rror message):

    #apache startup script
    HTTPD_SERVICE httpd

    Now the message LIB_SSL_PATH not defined appears.

    I added the lines to point to the LIB_SSL_PATH:

    LIB_SSL_PATH /lib/libss.so.2
    LIB_CRYPTO_PATH /lib/libcrypt.so.1

    Now CLIENT_PHP_BIN is not defined either.

    I added the line:

    CLIENT_PHP_BIN /usr/local/psa/bin/php-cli

    Your file names and locations may vary slightly from what I did. My Fedora Core server was slightly different.

    :D The Plesk Login Screen Appears! (You may want to thank me - I accept cash)

    I now have service restored to my email as well.
     
Loading...