1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail server problems

Discussion in 'Plesk 11.x for Linux' started by Lenvanessen, Sep 19, 2012.

  1. Lenvanessen

    Lenvanessen New Pleskian

    11
     
    Joined:
    Sep 7, 2012
    Messages:
    14
    Likes Received:
    0
    Hello,

    I'm always experiencing problems with the plesk mail server, and every time it's the smtp server.

    Can anyone tell me what the correct settings are? I'm running the most recent version of plesk.
    But no mail client can autodetect the settings, and i've tried a lot of difforent ports and authentication settings but nothing seems to work for me.

    Anyone have any ideas?

    Ps. what should the correct settings be? and is your email adress your login name?
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    You have not told us the problems you experience with SMTP. And about
    Yes that can be the case if that is what you set in Tools & Settings -> Mail Server Settings
     
  3. Lenvanessen

    Lenvanessen New Pleskian

    11
     
    Joined:
    Sep 7, 2012
    Messages:
    14
    Likes Received:
    0
    Smtp

    Hello,

    I can't connect to it from thunderbird, outlook or any mail client. Webmail works fine.
    I'm also experiencing the same problem with imap, i can't connect to it.
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
  5. Lenvanessen

    Lenvanessen New Pleskian

    11
     
    Joined:
    Sep 7, 2012
    Messages:
    14
    Likes Received:
    0
    Hello all,

    It was my ISP that blocked port 25. I've added port 2025 to postfix listeners and now it works.
    Thanks
     
  6. Hostasaurus.Com

    Hostasaurus.Com Regular Pleskian

    30
    68%
    Joined:
    Oct 8, 2009
    Messages:
    465
    Likes Received:
    8
    Unless your ISP is also blocking port 587, which would be very rare, you should simply turn on "Enable submission" under the mail server settings in Plesk; that will enable listening on 587 which you can use instead of 25.

    The reason you should do this is not only because 587 is a standard, but from one version of Plesk to the next, Parallels has been known to change the parameters associated with smtp listeners so you may end up upgrading at some point and your mail service stops working correctly, whereas if you're using their supported alternate port enabled by Plesk, it will update the associated config.
     
Loading...