1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Plesk 10.3.1 Component Updates Won't Install

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by MikeConoo, Aug 1, 2011.

  1. MikeConoo

    MikeConoo Guest

    0
     
    Updater states "Component updates are available" for Parallels Plesk Panel v 10.3.1

    Clicking "Update Components" displays 2 tick boxes:

    Different Apache web server versions: Apache web server support
    Different MySQL server versions: MySQL server support

    Clicked 'Continue'...

    States "Some errors occurred during installation. Download error log"

    Downloaded error log, and last part states:

    How do I fix this error to allow installation to continue?
     
  2. FrantišekH

    FrantišekH New Pleskian

    16
    60%
    Joined:
    Sep 13, 2010
    Messages:
    21
    Likes Received:
    0
    Reporting the similar situation (just the Apache, not MySQL line). It was the same with version 10.3.0.

    What to do?
     
  3. MatthiasHi

    MatthiasHi Guest

    0
     
    Same situation here. 10.3.1 running on CentOS 5.6
     
  4. jnimmo

    jnimmo Guest

    0
     
    I am also having this problem on a brand new Plesk installation
     
  5. Timvh

    Timvh Guest

    0
     
    Me too on 10.3.1 with CENTOS 5.5
     
  6. MikeConoo

    MikeConoo Guest

    0
     
    I'm still investigating.

    Tried running bootstrapper.sh repair and I found I got same error as when I ran upgrade from 10.2 to 10.3.1, couldn't connect to APS terminated the install.

    I think this issue is that autoinstaller hadn't finished to the end, leaving some components left requiring updating.

    Also, since this problem my system backup are constantly failing, and again may be related to APS connection.
     
  7. Timvh

    Timvh Guest

    0
     
    My case is a single server:

    Getting message that there are updates:

    # Different Apache web server versions: Apache web server support
    # Different MySQL server versions: MySQL server support

    After updating them getting error:

    repository: Get full packages info for all sources
    Bezig met ophalen van informatie over de geïnstalleerde pakketten...
    Execute command rpm -qa --queryformat 'F:system_installed_%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\nN:%{NAME}\nE:%{EPOCH}\nV:%{VERSION}\nL:%{RELEASE}\nA:%{ARCH}\nf:%{INSTALLTIME}\nB:%{BUILDTIME}\n[R:%{REQUIRENAME} %{REQUIREFLAGS:depflags} %{REQUIREVERSION}\n][P:%{PROVIDENAME} %{PROVIDEFLAGS:depflags} %{PROVIDEVERSION}\n][P:%{FILENAMES}\nm:%{FILEMODES}\n5:%{FILEMD5S}%{FILELINKTOS}\n][C:%{CONFLICTNAME} %{CONFLICTFLAGS:depflags} %{CONFLICTVERSION}\n][O:%{OBSOLETENAME} %{OBSOLETEFLAGS:depflags} %{OBSOLETEVERSION}\n]X:\n' > /tmp/autoinstaller_system_packages.cache
    Installation started in background
    read cache file
    (update package names cache) Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/update-rpm-CentOS-5-x86_64/)/update-10.3.1-cos5-x86_64.hdr.gz
    Downloaden van het bestanden PSA_10.3.1/update-rpm-CentOS-5-x86_64/update-10.3.1-cos5-x86_64.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/update-rpm-CentOS-5-x86_64/update-10.3.1-cos5-x86_64.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/)/thirdparty-10.3.1-cos5-x86_64.hdr.gz
    Downloaden van het bestanden PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/thirdparty-10.3.1-cos5-x86_64.hdr.gz: 11%..21%..42%..52%..67%..70%..92%..100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/thirdparty-rpm-CentOS-5-x86_64/thirdparty-10.3.1-cos5-x86_64.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (PSA_10.3.1/dist-rpm-CentOS-5-x86_64/)/build-10.3.1-cos5-x86_64.hdr.gz
    Downloaden van het bestanden PSA_10.3.1/dist-rpm-CentOS-5-x86_64/build-10.3.1-cos5-x86_64.hdr.gz: 10%..20%..31%..41%..50%..60%..71%..80%..90%..100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/PSA_10.3.1/dist-rpm-CentOS-5-x86_64/build-10.3.1-cos5-x86_64.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/)/thirdparty-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz: 100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/)/build-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz: 10%..22%..30%..45%..50%..61%..70%..81%..91%..100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/update-rpm-RedHat-all-all/)/update-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden BILLING_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz: 100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/)/update-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz: 100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/SITEBUILDER_10.3.0/update-rpm-RedHat-all-all/update-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/dist-rpm-RedHat-all-all/)/build-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden BILLING_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz: 10%..20%..31%..40%..50%..60%..70%..84%..91%..100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/dist-rpm-RedHat-all-all/build-10.3.0-rhall-all.hdr.gz
    Get full packages info from headers.
    FileFetcher: get file (BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/)/thirdparty-10.3.0-rhall-all.hdr.gz
    Downloaden van het bestanden BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz: 100% gereed.
    autoinstaller: read output of gunzip --stdout /root/parallels/BILLING_10.3.0/thirdparty-rpm-RedHat-all-all/thirdparty-10.3.0-rhall-all.hdr.gz
    Bezig met vaststellen welke pakketten moeten worden geïnstalleerd.

    Getting bootstrapper packages to installation list:
    (update package names cache) skip package 'pp10.12.0-bootstrapper-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system pp10.12.0-bootstrapper-10.12.0-cos5.build1012110629.18.x86_64)
    Following bootstrapper packages will be installed: (empty)
    ----------------

    Getting packages to installation list:
    skip package 'plesk-base-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system plesk-base-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'plesk-core-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system plesk-core-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'plesk-l10n-10.12.0-cos5.build1012110727.11.noarch' from component base - there is same or newer version of this package is installed (in system plesk-l10n-10.12.0-cos5.build1012110727.11.noarch)
    skip package 'plesk-skins-10.12.0-11062815.noarch' from component base - there is same or newer version of this package is installed (in system plesk-skins-10.12.0-11062815.noarch)
    skip package 'psa-10.3.1-cos5.build1012110718.17.x86_64' from component base - there is same or newer version of this package is installed (in system psa-10.3.1-cos5.build1012110718.17.x86_64)
    skip package 'psa-awstats-configurator-10.12.0-cos5.build1012110525.15.noarch' from component base - there is same or newer version of this package is installed (in system psa-awstats-configurator-10.12.0-cos5.build1012110525.15.noarch)
    skip package 'psa-libpam-plesk-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system psa-libpam-plesk-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'psa-locale-base-en-US-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-locale-base-en-US-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-logrotate-3.7-cos5.build1012110525.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-logrotate-3.7-cos5.build1012110525.15.x86_64)
    skip package 'psa-mod-fcgid-configurator-2.0.0-cos5.build1012110525.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-mod-fcgid-configurator-2.0.0-cos5.build1012110525.15.x86_64)
    skip package 'psa-mod_fcgid-2.3.6-11052615.x86_64' from component base - there is same or newer version of this package is installed (in system psa-mod_fcgid-2.3.6-11052615.x86_64)
    skip package 'psa-proftpd-1.3.3e-cos5.build1012110526.15.x86_64' from component base - there is same or newer version of this package is installed (in system psa-proftpd-1.3.3e-cos5.build1012110526.15.x86_64)
    skip package 'psa-pylibplesk-10.12.0-cos5.build1012110629.18.x86_64' from component base - there is same or newer version of this package is installed (in system psa-pylibplesk-10.12.0-cos5.build1012110629.18.x86_64)
    skip package 'psa-selinux-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-selinux-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-triggers-10.12.0-cos5.build1012110629.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-triggers-10.12.0-cos5.build1012110629.18.noarch)
    skip package 'psa-updates-10.3.0-cos5.build1012110525.15.noarch' from component base - there is same or newer version of this package is installed (in system psa-updates-10.3.0-cos5.build1012110525.15.noarch)
    skip package 'psa-vhost-10.12.0-cos5.build1012110601.18.noarch' from component base - there is same or newer version of this package is installed (in system psa-vhost-10.12.0-cos5.build1012110601.18.noarch)
    skip keypackage 'psa-10.3.1-cos5.build1012110718.17.x86_64' from component base - same or newer version of this package is already installed (in system psa-10.3.1-cos5.build1012110718.17.x86_64)
    Following packages will be installed: (empty)
    ----------------
    Patch will not be installed since it is already applied.
    Execute command chcon system_u:eek:bject_r:bin_t:s0 /usr/local/psa/admin/bin/send-error-report
    Execute command /usr/local/psa/admin/bin/send-error-report install
    Execute command /usr/sbin/getenforce
    Disabled
    Error: U beschikt al over de laatste versie van het product (de producten) en alle geselecteerde componenten. De installatie zal niet worden vervolgd.

    Translation of error:

    Error: U beschikt al over de laatste versie van het product (de producten) en alle geselecteerde componenten. De installatie zal niet worden vervolgd.

    Error: You already have the latest version of product(s) and all selected components
    installed. Installation will not continue.
     
  8. mheilmann

    mheilmann Guest

    0
     
    Any solution yet? Same Problem here:
    # Different Apache web server versions: Apache web server support
    # Different MySQL server versions: MySQL server support
    are available but update fails as each is "already installed".
     
  9. MikeConoo

    MikeConoo Guest

    0
     
    Sadly no fix for this yet.

    I did get my bootstrapper.sh repair to work after following an instruction elsewhere in forum to comment out skip-networking in /etc/my.cnf. This allowed the installer to run successfully to the end.

    I thought this would resolve this issue, but I still have the same problem with 2 component updates that won't install because they're already installed?
     
  10. holgenoni

    holgenoni Guest

    0
     
    Hello, same problem here after update.

    My bigger problem is that after this update no fastcgi works!

    Does anyone know how to solve that?

    Best regards
     
  11. sPuR

    sPuR Guest

    0
     
    I got these errors.

    File downloading MYSQL_5.5/mysql-5.5-rhel5-x86_64.inf3: 78%..100% was finished.
    Warning: ez_template_suffix is NOT defined in MYSQL_5.5/mysql-5.5-rhel5-x86_64.inf3
    Attach addon APACHE_2_2_19 to release Parallels Plesk Panel 10.3.1
    FileFetcher: get file (~empty)/APACHE_2.2.19/apache-2.2.19-rh5-x86_64.inf3
    File downloading APACHE_2.2.19/apache-2.2.19-rh5-x86_64.inf3: 90%..100% was finished.
    Warning: ez_template_suffix is NOT defined in APACHE_2.2.19/apache-2.2.19-rh5-x86_64.inf3

    No idea what happen here, but it just skipped over trying to update these two for me, but also having problems with backups now too. I can backup domains, but not server configuration.

    Shawn
     
  12. tino

    tino Basic Pleskian

    24
    23%
    Joined:
    Mar 6, 2008
    Messages:
    70
    Likes Received:
    0
    I can confirm I have this same problem.

    These remain;

    # Different Apache web server versions: Apache web server support
    # Different MySQL server versions: MySQL server support

    And trying to update them would cause the update to fail with an 'allready installed' error.

    Tino
     
  13. jterry

    jterry Basic Pleskian

    24
    23%
    Joined:
    Jan 22, 2004
    Messages:
    53
    Likes Received:
    0
    Hello

    I've this problem also 10.3.1 CentOS 5.6 x86_64, two months old, barely used.

    Will this auto fix "alone" or must wait (and search) for a manual patch?

    Thanks.
     
    Last edited: Sep 9, 2011
  14. jola

    jola Basic Pleskian

    19
    60%
    Joined:
    Dec 26, 2010
    Messages:
    40
    Likes Received:
    1
    I have the same problem after upgrading to 10.3.1.
     
  15. Dennisehv

    Dennisehv New Pleskian

    13
    35%
    Joined:
    Jun 13, 2011
    Messages:
    18
    Likes Received:
    0
    Same..

    Plesk 10.3.1 (CentOS release 5.6)

    skip keypackage 'psa-10.3.1-cos5.build1012110718.17.x86_64' from component base - same or newer version of this package is already installed (in system psa-10.3.1-cos5.build1012110718.17.x86_64)
    Patch will not be installed since it is already applied.

    skip keypackage 'mysql-server-5.0.77-4.el5_6.6.x86_64' from component mysql-sys - same or newer version of this package is already installed (in system mysql-server-5.0.77-4.el5_6.6.x86_64)
    Patch will not be installed since it is already applied.
     
  16. Farsus

    Farsus Basic Pleskian

    23
     
    Joined:
    Sep 1, 2005
    Messages:
    44
    Likes Received:
    0
    Any one found a solution to this problem its realy tiring problem everytime there is a MU i hope this time it will be gone but it still there !!
     
  17. ip00

    ip00 New Pleskian

    17
    60%
    Joined:
    Sep 29, 2011
    Messages:
    18
    Likes Received:
    0
    I'm also having the same problem:

    > Parallels Plesk Panel v. 10.3.1: Component updates are available
    - Different Apache web server versions: Apache web server support

    It fails every time.
     
  18. ip00

    ip00 New Pleskian

    17
    60%
    Joined:
    Sep 29, 2011
    Messages:
    18
    Likes Received:
    0
    I haven't been able to solve this. Someone else? Parallels tech?
     
  19. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Did you try to use

    ?
     
  20. ip00

    ip00 New Pleskian

    17
    60%
    Joined:
    Sep 29, 2011
    Messages:
    18
    Likes Received:
    0
    I did right now, and the result is pretty much the same as with Power Panel. Screenshots attached:
     

    Attached Files:

Loading...