• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Problem with plesk update

Breitner

New Pleskian
Hi there,

I'm using Plesk 12.0.18 with Ubuntu 12.04.2 LTS
Last automatic update gave me an error, this is the log :

../...
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
Warning: there are errors in 'apt-get update'
Detecting installed product components.
Gathering information about installed license key...
Launching component checkers...
File downloading PSA_12.0.18/examiners/panel_preupgrade_checker.php: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
File downloading PSA_12.0.18/examiners/php_launcher.sh: 100% was finished.
Checking whether the package dependencies are resolved.
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
---X--- `apt-get` output ---------------------
~empty
---------------------- `apt-get` output ---X---
Collecting error details into log file...

ERROR: Installation will not continue

The apg-get failed with the following message:

Not all packages were installed.
Please, contact product technical support.

So i tried to manually run dpkg, restart plesk and waiting for next update but error still here.
This is the first kind of error since i run plesk for few years.

Anyone could help to resolve ?

Thanks a lot,

Best regards,

Sébastien
 
Try to run update process manually with

# /usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base

and check errors in output or in /tmp/autoinstaller3.log file?
 
Hi Igor,

I've just tried to manually update.
Plesk is now indicate :
Version de Plesk 12.0.18 Mise à jour n° 68, dernière mise à jour à 7 Oct 2015 16:40
It seems that your advice works.

This is the end of the log :
Patch plesk-12.0.18~patch68 installation summary: 592 items applied, 10 items skipped, 0 items failed.
Patches were installed successfully.

All good ?

Thanks so much for your help,

Best regards

Sébastien
 
Back
Top